CentOS 7: error: system does not fully support snapd: cannot read the value of fs.may_detach_mounts kernel parameter

Unable to install redis-desktop-manager on centOS 7.

$ sudo snap install redis-desktop-manager
error: system does not fully support snapd: cannot read the value of
         fs.may_detach_mounts kernel parameter: open
         /proc/sys/fs/may_detach_mounts: no such file or directory

Details:

Operating System:

[root@localhost ~]$ cat /etc/os-release 
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

Snap Version:

[root@localhost ~]$ snap --version
snap    2.42.2-1.el7
snapd   2.42.2-1.el7
series  16
centos  7
kernel  3.10.0-327.el7.x86_64

Your kernel is too old. According to RPM changelog, your package release is:

* Thu Oct 29 2015 Rafael Aquini <aquini@redhat.com> [3.10.0-327.el7]

Please update to at least 3.10.0-620.el7. However, given the amount of fixes backported to the EL kernels, I suggest you go with the latest one.

2 Likes

Ok let me try upgrading my OS and try again. Thanks :slight_smile:

Thanks for the help! Upgrading kernel certainly fixed it.

[user@localhost ~]$ snap --version
snap    2.42.2-1.el7
snapd   2.42.2-1.el7
series  16
centos  7
kernel  5.4.1-1.el7.elrepo.x86_64

But then received this warning. (Restarting or Logout didn’t help)

user@localhost ~]$ sudo snap install redis-desktop-manager
2019-11-29T13:45:09-08:00 INFO Waiting for restart...
Warning: /var/lib/snapd/snap/bin was not found in your $PATH. If you've not restarted your session
         since you installed snapd, try doing that. Please see https://forum.snapcraft.io/t/9469
         for more details.

I had to add /var/lib/snapd/snap/bin in the $PATH variable

vi ~/bash_profile
export PATH=$PATH:/var/lib/snapd/snap/bin

That fixed the warning from showing up. In case any one else is running into similar issues.

AFAIK, this is because when running under sudo, your $PATH is reset:

[guest@localhost ~]$ echo $PATH
/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/var/lib/snapd/snap/bin:/home/guest/.local/bin:/home/guest/bin
[guest@localhost ~]$ sudo sh -c 'echo $PATH'
/sbin:/bin:/usr/sbin:/usr/bin

And it’s controlled by the default policy for sudo:

[guest@localhost ~]$ sudo grep -n -e 'Defaults.*env_reset' -e 'Defaults.*secure_path' /etc/sudoers
75:Defaults    env_reset
88:Defaults    secure_path = /sbin:/bin:/usr/sbin:/usr/bin
1 Like

@mborzecki @dinbtechit
also encountered the same problem

  • I followed the command as follows
# admin @ Msg in ~ [15:38:23] 
$ sudo snap install wekan
[sudo] password for admin: 
error: system does not fully support snapd: cannot read the value of fs.may_detach_mounts kernel
       parameter: open /proc/sys/fs/may_detach_mounts: no such file or directory
  • The relevant information
# admin @ Msg in ~ [15:59:21] 
$ lsb_release  -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch
Distributor ID:	CentOS
Description:	CentOS Linux release 7.0.1406 (Core) 
Release:	7.0.1406
Codename:	Core
# admin @ Msg in ~ [15:59:25] 
$ uname -r  
3.10.0-123.9.3.el7.x86_64
# admin @ Msg in ~ [16:02:53] 
$ snap --version
snap    2.43.3-1.el7
snapd   2.43.3-1.el7
series  16
centos  7
kernel  3.10.0-123.9.3.el7.x86_64
  • Can not upgrading the kernel solve this problem?

Your kernel is too old. According to RPM changelog, your package release is:
Thu Oct 29 2015 Rafael Aquini <aquini@redhat.com> [3.10.0-327.el7]
Please update to at least 3.10.0-620.el7. However, given the amount of fixes backported to the EL kernels, I suggest you go with the latest one.

Are you using the stock centos 7 kernel? Is it at least 3.10.0-620.el7?

I just updated the reply, I don’t understand the kernel very well, please kindly check

  • The relevant information

@mborzecki

# admin @ Msg in ~ [16:02:56] 
$ cat /proc/version 
Linux version 3.10.0-123.9.3.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.2 20140120 (Red Hat 4.8.2-16) (GCC) ) #1 SMP Thu Nov 6 15:06:03 UTC 2014

@mborzecki
Since my server was used for production, I was worried that updating the kernel would cause some problems.
If there are no other problems with upgrading the kernel, I can consider upgrading the kernel.
Thank you very much for taking the time to answer my questions😀

@mborzecki

Can you help me? Looking forward to your reply. Thank you!

This is the kernel version you need 3.10.0-620.el7, while this is the version you have: 3.10.0-123.9.3.el7.

As for any problems updating the kernel on CentOS7, I think you are better off asking questions in the relevant CentOS/RHEL mailing lists or forums.

1 Like