CEF in a strict snap

Hi all,

I have been trying to include the generic prebuilt CEFs by Spotify in a Snap with strict containment.
I had some success but I could never get the sound working (everything works outside of a snap and in classic/devmode snap).
If anyone has had any experience with this problem, a solution or just some general observations please reply to this Topic!
Any help would be great!

Are you using either the snapcraft-desktop-helpers or the gnome-3-28 extension? It is likely that your app doesn’t have a complete working environment to point to the pulseaudio stack, which would be set-up by using either of the above.

Sorry for the late reply but I have copied almost everything with little changes from https://git.launchpad.net/~chromium-team/chromium-browser/+git/snap-from-source/tree/snapcraft.yaml and sound doesn’t work.
I tried with gnome-3-34 too but it still doesn’t work.
I am using the official CEF builds from http://opensource.spotify.com/cefbuilds/index.html#linux64.

CEF seems to just not be well or at all supported, despite chromium working ok.

Any help would be greatly appreciated!

I found a solution.
The latest Spotify CEF build at the time of writing + gnome-3-34 ( cef_binary_86.0.18+gd3ead8b+chromium-86.0.4240.111 fixed the pulse audio binding and the mp3 audio support. (YouTube with VP8/9 works too)

Tested on Ubuntu, Fedora and Manjaro.

1 Like