Can't update apps

For the past two days I am not able to update any applications that are snap based on my Ubuntu 20.10 system. I have even tried uninstalled snapd with no avil.
snap 2.48.3+20.10
snapd 2.48.3+20.10
series 16
ubuntu 20.10
kernel 5.8.0-44-generic

Screenshot from 2021-03-08 18-00-57 Screenshot from 2021-03-08 18-25-45

why did you delete /var/lib/snapd/system-key ?

Rightly or wrongly, that recommendation turns up in multiple places, including here as one step in a way to unbreak a system.


You are correct. In my haste to fix it I found a forum post regrading how that person fixed their issue by deleting it, removing snapd and reinstalling it worked for them.

The system-key file is harmless to delete, it will be re-calculated by snapd if it is missing. There have been bugs where that file is not updated when it should be, but that file being missing means that snapd would re-generate all the AppArmor profiles etc. which incurs a time cost but otherwise is harmless.

1 Like

The real error here is from invalid credentials which Iā€™m not sure what would cause that, do you still have the original system available to run some debug commands on ?

Ha interestingly enough I just ran into this issue myself without realizing it, I changed my ubuntu SSO password, and the token that my device was using since I ran snap login on that device then was revoked, and it was failing with the same exact errors. So if you are running into this and you recently changed your password or otherwise revoked access to macaroons for your account via SSO, then you need to re-login with

snap logout
sudo snap login
... enter your login credentials here

If you still see the issue after relogging in this way, let us know and we can continue to debug it with you.


Dang it! You are absolutely correct. I just changed my Ubuntu SSO password a few days ago. šŸ¤¦

1 Like