Can't run Godot 3.0.6 snap on peppermint linux, got this error pic:


#1

Hello I got the error on the picture below. I just tried “snap install autoskola3d” and I got this error: initialize: X11 display is not avalable! Any ideas or help please? Thanks in advance…


#2

Are you running on Wayland withouth Xserver? Perhaps the application only supports x11.


#3

I was just testing snap downloads (snap install autoskola3d) on various linux versions. It worked on Ubuntu 18.04 out of the box, it worked on Linux Mint 19 out of the box, then I tried peppermint linux 18.04 and it did not work with this error. Maybe peppermint linux is built only with wayland without x11. Is it possible to install additionaly x11 to peppermint or do I have to? On Linux Mint I have working program like this one on the pic:


#4

Then I had an idea to change YAML snap file during the proccess of creation of the snap like I did it in “snap install autoskola-free6” There I can see with electron app mounting wayland and capability of usage of wayland within this app. Do you think Godot engine app 3.0.6 is capable of using wayland? Or is it just legacy app dependent only on X11?