Can't move bluez to --edge channel

Hardware: Dell Edge Gateway 3002
OS: Ubuntu Core

Have tried moving bluez snap to --edge channel and refreshing, and also removing bluez and reinstalling from --edge channel but both are returning an error that the snap is not available, while ‘snap info bluez’ does show an edge version available. Any thoughts? Thanks


Well that’s interesting. What’s the output of snap version - I wonder if you’re on a super old version of snapd.
Also, are you using a store other than the global one? if you run sudo snap get core -d do you see anything interesting about which store is in use?

Thanks - it’s using the stock Ubuntu Core 16 that’s factory installed by Dell.


The Dell 300x gateways implement Refresh Control, a feature of the snap store which allows an extra level of validation to be required before a snap can be installed.

If you really want to install the version of bluez from edge, just add the command line option --ignore-validation to your snap refresh command.

That said, while its interesting that a version of bluez 5.49 is available in the edge channel, there are no guarantees that this will ever be released to latest/stable.

1 Like

Excellent - thanks Tony, that worked!

We have an issue with Bluetooth on the GW3002 whereby it’s crashing after pairing with a mobile device. Same source running on an RasbPi 3b+ w/ Bluez v5.52 works OK, hence the need to try it with a more recent version of Bluez. I’ll open another thread for that if we’re still seeing a problem.