Can't login to wiki.ubuntu`

I’m trying to login to to add a remote part.

Each time I’ve tried to login over the past week it crashes after a very long time trying to do the openid verification.

I have a ubuntu one account, though it does seem a bit odd that I should be able to just login an edit the wiki page given how sensitive the whole eco system is to this particular page.

So I’m I supposed to login or is there some way of getting permission to publish a remote part?

The error (which takes several minutes to appear) is:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: Error reading from remote server

The url when the error is displayed is:

I just tried logging in to the wiki in a new browser and it certainly took a while. I’ll file an RT with our IS people to see if they can look into the issue.

I’d try again. Also make sure you’re in the ubuntu-wiki-editors group, which controls access to the wiki. Join the team and someone (likely me) will approve it.

Yeah, it is generally pretty slow and problematic to log in to. I have been trying for about 15 minutes so far. I just wanted to post the beta 1 release announcement so that all the flavours (if they wished) could easily reference in social media, etc.)