Can't launch gimp snap

I am running Kubuntu 18.04…I enabled snapd from discovery app. Went to snap store and installed gimp 2.10. There is no listing under installed apps to launch the gimp snap. when I try it from the terminal it launches gimp 2.8. I tried from terminal gimp 2.10 to see if that would launch it, but it still launches 2.8 it says 2.10 can not be found.

I did notice a change into where the snap directory is stored. In older versions it used to be installed in my /home folder, meaning /home/snap. I could not find it there so I did some digging. It is installed in my root folder meaning root/snap.

Maybe I am wrong but i am pretty sure I remember the snap folder being installed in my home folder not my root folder. I checked out the snap folder and gimp is indeed installed. Should I try to just move the folder from /root to /home? Then do a restart or is there a bug that hasn’t been fixed that I am unaware of?

Please launch Konsole and paste printenv | grep snap command’s output

@home:~$ printenv | grep snap

Nothing wrong in particular…

Please restart your user session (i.e. log out & re-login, or reboot) and verify if the issue is still reproduced.

The proper locations are $HOME/snap and /snap, which are both valid for different purposes, refer The system /snap directory - Documentation for snaps: Universal Linux packages for more info.

Ok, This may seem weird but I first had to boot from an older kernel 4.15.0-39.41. I was then able to launch gimp 2.10 from my app launcher. So I immediately renamed the app in the launcher to gimp 2.10 because I had 2.8 pinned to the panel.
So for the hell of it I then rebooted again into my latest kernel 4.15.0-39.42, and now both gimp 2.10 shows up in the launcher with the older gimp right underneath it. They both work now.

Don’t know why back tracking to the older kernel, did the trick, but I also notice now indeed a folder in /home labeled snap . So I now have /Home/snap/gimp and /Root/snap/ bin core core18 gimp gtk-common-themes README. SO I guess for now Things are working as they should.

Funny thing is I tried rebooting a few times into the new kernel first before posting and could "not"get it to start.

Whadda ya think?? Am I nuts or did I find something?

Were you at any time during the testing running an unsupported kernel? If so, then that will likely cause problems.

Hi Popey big fan, listen to you all the time on LAS & Unplugged. To answer your question, this kernel popped up on discover yesterday. I’ve had no problems with new recommended kernels so I installed it. I made a typo in my previous post I had to look up the full version in synaptic, uname -r was just giving me to 39, not the latest point release. The full release is “4.15.0-39.42”. I was previously on 4.15.0-39.41. I only have the default settings in discover, although just now I tried to find software sources to make sure nothing has changed on the top right of the discover panel and software sources is gone, can’t find them now.
Here is my full run down:
KDE Plasma V: 5.12.6
KDE Frameworks V: 5.44.0
QT V :5.9.5
OS: 64-bit
CPU: Core2Quad 2,66GHz
Syst Mem: 4GiB
NVidia Geforce 650 1Gib Memory

All is working now was just using the new Gimp 2.10 works fine.

I just can’t find my software sources now.

1 Like

I found the software sources, my bad. Instead of Ubuntu being on top, Snap is on top of the panel in Discover if anyone else can’t find their software sources. the dropdown triangle is still top right, just not all the way on top, it’s under Snaps.