Can't connect to League of Legends

When I try to open the League of Legends snap, the client opens but I always get the message “we are unable to log you in because you may be offline.” It will let me log in maybe one out of every 20 tries I try restarting the client, but that’s only if I’m lucky. I allowed all of the League of Legends ports in my ufw settings but that still doesn’t help. I also tried reinstalling the game completely but that didn’t help either. I’m on the latest version of Ubuntu and latest version of snap. I think I might know a fix but it requires me to edit the config file located in the install directory but I can’t seem to find that either, all of the snap folders for LoL end up being empty. Where can I find where snap installed the actual game files? If anybody knows the actual fix for this then please let me know. Thank you.

Hi all,

Exactly same scenario here.
I found the official RIOT games fix but to implement require change to the file located in Game files location (dunno where to look for it). For some reason i was able to run it few days back after like 3-5 attempts. Now i cannot get authenticated at all.

Steps Taken:
-Installed again
-refreshed snap
-ran in --devmode

Anyhelp appreciated!

Check this,

@mmtrt that didn’t work, I tried reinstalling the league of legends snap after I updated wine-platform to 4.3 but now after installing the league of legends snap the downloader freezes

Works fine here though game installer is very much buggy on wine tends to break so It would be easy if game data is copied from elsewhere to ease setup process.


@mmtrt How would I go about doing that?

  • Grab updated game if you have it installed somewhere i.e in windows partitions OR you have installed by game from lutris then find it from its wineprefix don’t know where this is stored.
  • Copy Riot Games to /home/$USER/snap/leagueoflegends/common/.wine/drive_c/

@mmtrt I still get stuck at this screen