The issue may be that the highest version of the grub-efi-amd64-signed deb for a system that uses focal-updates and the uc-staging-ppa PPA is 2:1.167.2+2.04-1ubuntu44.2. This lives in the PPA. This version requires a specific version of grub-efi-amd64-bin (= 2.04-1ubuntu44.2), but there is a higher version of that package in focal-updates archive (2.04-1ubuntu47.4), so grub-efi-amd64-signed cannot be installed as needed to build the gadget.
The resolution may be to bump the version (and requirements) of the grub-efi-amd64-signed and grub-efi-amd64-bin packages in the PPA so that they are higher than the ones in the focal-update archive.
The pc-amd64-gadget snapcraft.yaml specifies the following PPA:
It then adds the following deb to the snap:
The grub-efi-amd64-signed in the PPA version is: 2.167.2+2.04-1ubuntu44.2
$ apt policy grub-efi-amd64-signed
500 http://ppa.launchpad.net/ucdev/uc-staging-ppa/ubuntu focal/main amd64 Packages
[ . . . ]
This version of grub-efi-amd64-signed depends on a specific version of grub-efi-amd64-bin:
$ sudo apt install -s grub-efi-amd64-signed
[ . . . ]
The following packages have unmet dependencies:
grub-efi-amd64-signed : Depends: grub-efi-amd64-bin (= 2.04-1ubuntu44.2)
But, the focal-updates archive has a higher version of that package:
$ apt policy grub-efi-amd64-bin
*** 2.04-1ubuntu47.4 500
500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
I think this means the first package cannot be installed because it requires grub-efi-amd64-bin (= 2.04-1ubuntu44.2) but grub-efi-amd64-bin 2.04-1ubuntu47.4 it the highest available.