Cannot upload to store

I tried to push my snap today as a beta release, but got this message:

Pushing kstars_2.9.3_amd64.snap
There was an error uploading the package.
Reason: ‘Internal Server Error’
Text: ‘\nOops! - OOPS-82aa43547a330c77128a5c8cf42fd7cd\n\n



Something broke while generating the page.\nPlease try again in a few minutes, and if the problem persists file\na bug or contact customer support. Please quote OOPS-ID\nOOPS-82aa43547a330c77128a5c8cf42fd7cd\n

So after a while, I tried again, but now I got this:

Error while processing…
The store was unable to accept this snap.

  • binary_sha3_384: A file with this exact same content has already been uploaded

Is there a way to fix this?


I’m looking into it now. As a workaround, can you try re-pushing your snap? Please let me know whether it worked or not.

  • Daniel

@roadmr He said he tried again, and couldn’t:

@mutlaqja Most likely your upload actually worked, despite the error. Have you looked into the dashboard to see if your new revision is there?

Also, from the cli,

$ snapcraft list-revisions kstarts | head

From CLI, I get this:
Rev. Uploaded Arch Version Channels
9 2018-02-27T10:36:25Z amd64 2.9.3 -
8 2018-01-13T23:01:49Z amd64 master+38b187e edge*
7 2018-01-13T22:39:51Z amd64 master+38b187e edge
6 2018-01-13T21:58:01Z amd64 master+38b187e edge
5 2017-11-16T15:28:56Z amd64 master+08a6231 edge
4 2017-10-12T14:15:20Z amd64 master+18a353c edge
3 2017-09-21T09:39:37Z amd64 master+1f584ff edge
2 2017-09-15T15:56:10Z amd64 master+bee034f -
1 2017-03-10T09:35:41Z amd64 2.7.5

And from the Dashboard, I see the same thing with 2.9.3 as ‘unpublished’ and pending review.


I’ve re-triggered the automated review and it’s now complete.

1 Like

Thanks, the review failed due to this:

package contains external symlinks: usr/lib/x86_64-linux-gnu/ lint-snap-v2_external_symlinks

Any ideas how to resolve this? Also, I think I will rebuild the snap in “classic” confinement mode, is it OK if I reupload later with the same version number?

The symlink is pointing to outside the snap, which is almost certainly not what you’re trying to do I’d guess? The fix is shipping the library it needs to use within the snap itself.

How do I control that? Shouldn’t snapcraft take care of that? I will see what links exactly to libusb since many binaries within the snap depend on libusb.

I ran into a similar issue with the Restic snap. Right now it states that it is pending review. Do I need to get anyone to push off the review since the upload kind of failed?

Ok, I reviewed in the web portal. In my case I built in a container with a mapped folder to my host. Then tried to push from there. Caused a permissions issue. Going to retry using cleanbuild.