Cannot update/install skype

Hello,

I was not able to update skype. Everytime I run “sudo snap refresh” I get an error about a missing libgo.so.16 library. After removing snapd completely and reinstalling snapd 2.49 I cannot install skype anymore.

Each time i run “sudo snap install skype” (doesn’t matter if adding the --classic flag) I get the following output:

error: cannot perform the following tasks:

  • Run configure hook of “skype” snap if present (run hook “configure”:

snap-update-ns: error while loading shared libraries: libgo.so.16: cannot open shared object file: No such file or directory
snap-update-ns failed with code 127
-----)

system is ArchLinux and snapd it the AUR snapd 2.49-1 package.

Other packages like android-studio don’t have this issue.
“snap list” shows:

Name Version Rev Tracking Publisher Notes
android-studio 4.1.2.0 100 latest/stable snapcrafters classic
core 16-2.49 10859 latest/stable canonical✓ core
core18 20210128 1988 latest/stable canonical✓ base
core20 20201210 904 latest/stable canonical✓ base
freecad 0.18 19 latest/stable vejmarie -
gnome-3-28-1804 3.28.0-19-g98f9e67.98f9e67 145 latest/stable canonical✓ -
gtk-common-themes 0.1-50-gf7627e4 1514 latest/stable canonical✓ -
snapd 2.49 11107 latest/stable canonical✓ snapd
uappexplorer-cli 1.0.0 2 latest/stable bhdouglass -

“snap info skype” shows (partial):

snap-id: QRDEfjn4WJYnm0FzDKwqqRZZI77awQEV
channels:
latest/stable: 8.69.0.77 2021-02-17 (164) 140MB -
latest/candidate: ↑
latest/beta: ↑
latest/edge: ↑
insider/stable: 8.69.76.49 2021-02-10 (163) 140MB -
insider/candidate: ↑
insider/beta: ↑
insider/edge: ↑

the system contains a libgo.so.16 file.

ls -l /usr/lib/libgo.*
-rw-r–r-- 1 root root 70047132 4. Feb 14:37 /usr/lib/libgo.a
lrwxrwxrwx 1 root root 15 4. Feb 14:37 /usr/lib/libgo.so -> libgo.so.16.0.0
lrwxrwxrwx 1 root root 15 4. Feb 14:37 /usr/lib/libgo.so.16 -> libgo.so.16.0.0
-rwxr-xr-x 1 root root 54901272 4. Feb 14:37 /usr/lib/libgo.so.16.0.0