Cannot start my app anymore

With the latest snapcraft, I cannot start my gtkmm-3 based application anymore. It just gives a Gtk::BuilderError and exits.

Since I use glade-3.38 to generate my .ui file, I thought maybe this is related to the version of gtkmm in core18, I tried to generate it with an older version but didn’t work. I also tried to build it with devmode and inspect via snappy-debug but got no output from it.

Here is the snapcraft.yaml

Any help is appreciated.

the full error output might be interesting here …

regarding your snapcraft.yaml, i noticed that you use webkit in your build-packages but do not ship the webkit lib in stage-packages (not sure if the gnome extension ships it)

The exact message is:

terminate called after throwing an instance of 'Gtk::BuilderError'
Aborted (core dumped)

I’ll try to add webkit package to stage packages as well. Thank you.

1 Like

@ogra Tried that but didn’t work since it was already building without webkit lib in stage packages because gnome extension includes this. The problem is in runtime and I suspect some glade convention style mismatch. Tried to generate the ui with old versions of glade but no luck so far…

1 Like