"cannot snap-exec: cannot read info" problem

Hi, I’m building my first snap and got stuck running it. Maybe someone more experiences could help me out.

When I’m running my snap I get “cannot snap-exec: cannot read info for “vbp-publisher”: cannot find installed snap “vbp-publisher” at revision x1: missing file /var/lib/snapd/snaps/vbp-publisher_x1.snap”

The “missing” file actually exists:

ls -la /var/lib/snapd/snaps/vbp-publisher_x1.snap
lrwxrwxrwx 1 root root 87 Aug  8 07:05 /var/lib/snapd/snaps/vbp-publisher_x1.snap -> /var/lib/.../prime

I built the snap using “sudo snap try prime/ --devmode”

The contents of snapcraft.yaml

name: vbp-publisher
version: '1.0'
summary: blabla
description: blabla
grade: devel
confinement: devmode

    command: dist/vbppub
     - network-bind

      source: .
      plugin: make
       - dist/vbppub

snap version:

$ snap version
snap    2.34.3
snapd   2.34.3
series  16
ubuntu  16.04
kernel  4.4.0-1054-aws

Did you try to simply build it by callig snapcraft and installing it with snap install --dangerous --devmode /path/to/snap ?

smells like an issue with the try mode to me …

That worked nicely. Thank you!

I took the “try” command from the tutorial: https://tutorials.ubuntu.com/tutorial/build-a-nodejs-service#2

snap try should work (I use it often!). How can I reproduce this error?

I tried to make a new snap with just one bash script. That worked nicely with the try command. Not sure what’s different with the other snap.