Cannot remove broken snap

Running Debian 11 (Bullseye), and I have run into a situation where I have a broken snap that cannot be removed or refreshed. Here is the snap list output:

Name                                  Version          Rev    Tracking       Publisher      Notes
bare                                                   5      latest/stable  canonical✓     broken
core20                                20230613         1950   latest/stable  canonical✓     base
core22                                20230612         766    latest/stable  canonical✓     base
cups                                                   962    latest/stable  openprinting✓  disabled,broken
gtk-common-themes                     0.1-81-g442e511  1535   latest/stable  canonical✓     -
kde-frameworks-5-96-qt-5-15-5-core20  5.96.0           7      latest/stable  kde✓           -
kde-frameworks-5-99-qt-5-15-7-core20  5.99.0           7      latest/stable  kde✓           -
snapd                                 2.59.5           19457  latest/stable  canonical✓     snapd

I had previously tried to uninstall / reinstall the disabled and broken snap, but it did not work, and is now showing up in this state. I went so far as to try and purge snap and snapd, but even after reinstalling, I am still left with these snaps in the list.

If I attempt to remove the snap, I get the following:

esonofander@penguin:~$ sudo snap remove cups
2023-06-29T14:46:58-07:00 ERROR cannot remove snap file "cups", will retry in 3 mins: 
umount: /snap/cups/962: not mounted.
Remove snap "cups" (962) from the system  

At which point, it will sit there and keep retrying and keep failing until I break out of it. If anybody has any suggestions, I would greatly appreciate it.

Here is the snap version info as well:

snap    2.49-1+deb11u2
snapd   2.49-1+deb11u2
series  16
debian  11
kernel  5.15.112-19388-gadccfcf84668

Edit: I am assuming the problem is related to the fact that I apparently am running an older version of snap, but when I install via apt, this is the most current version that it has available, even after doing an apt update. I have found no way of forcing an install of a newer version of snap/snapd.

have you tried to first enable it ?