Cannot mount squashfs image using "squashfs", and

Hello all,
I tried installing snap on my Ubuntu 18.04 server just to use Certbot, and thought a simple apt-get update && apt-get install snapd would make it easy. I thought wrong. I tried installing, and this was my error:

root@raw:~# snap install hello-world
error: system does not fully support snapd: cannot mount squashfs image using "squashfs": mount:
       /tmp/sanity-mountpoint-154055777: mount failed: Operation not permitted.

I looked into solutions such as typing sudo modprobe loop, however that doesn’t appear to exist on my machine:

root@raw:~# modprobe loop
modprobe: FATAL: Module loop not found in directory /lib/modules/4.15.18-16-pve

I’m not very experienced with Snap and this is my first time using it, so help is massively appreciated.

It looks like you’re using Proxmox VE. If your Ubuntu Server installation is using some form of PVE-specific containerisation, as seems to be the case because you’re using a non-Ubuntu kernel, then you are likely falling foul of their container security rules.

1 Like

That’s just due to my choice of server host - worth switching, or is there anything I can do as a consumer?

You could try apt installing squashfuse to use fuse squashfs which won’t hit the same kernel restrictions that exist for a container since it’s userspace. Unclear if snapd is detecting that it is running inside a container here (or is it running in an actual VM? Proxmox’s site doesn’t make it clear whether they do containers or real VM’s).

1 Like

From what I know, it’s running in a VM. Will try again when home.

Just encountered this issue and I’m 99% sure this is an LXC container, there’s workaround, though: