Cannot install application "cannot communicate with server: Get http://localhost/v2/changes/1"

When i install RocketChat-server on my Raspberry Pi Zero W it gives me this error:
error: cannot communicate with server: Get http://localhost/v2/changes/1: dial unix /run/snapd.socket: connect: connection refused
I have searched everywhere but i couldn’t find any help or fix

the error indicates that snapd is not running/could not start … since there is no Ubuntu support for the zero W, what distro are you running ?

I am running Raspbian stretch lite november 218
37

And the command i used is sudo snap install rocketchat-server from https://github.com/RocketChat/Rocket.Chat.RaspberryPi#easy-and-fast-installation-via-raspbian-stretch

well, the problem with the Pi ZERO W is that it has an old ARMv6 CPU, i guess that is the reason why it is explicitly not mentioned in that rocketchat doc (it only refers to pi2, 3 and 3b+ while the zero W is actually using the SoC from the original Pi 1).

while there is actually no reason for snapd itself to not start, you wont be able to execute arm snaps on this hardware because the minimal requirement for snap packages on ARM hardware is an ARMv7 CPU core in the SoC. The binary snaps are built for the armhf architecture …

EDIT: actually … take a look at the “addendum” block in the rocketchat doc … it links to a FAQ about the zero …

thanks for thw quick reply!
I looked at the FAQ but there’s nothing about rpi zero.
I have it succesfully installed on my RPI 3.
PS sorry for my bad English if it’s bad. (i’m 12 years old and Dutch :joy:)
Bye!

i think they refer to:

“Can Rocket.Chat run on Pi One - model B, model B+, or model A”

… and simply missed to add the Zero to that list (they are all using the old chip)

Your english is fine, no worries (at least for this german here reading it :wink: )

yeah i looked in their open.rocket.chat and they confirm it is because the 512 mb of ram 24

git clone https://github.com/DamionGans/ubuntu-wsl2-systemd-script.git
cd ubuntu-wsl2-systemd-script/
sudo bash ubuntu-wsl2-systemd-script.sh
# Enter your password and wait until the script has finished
cmd.exe /C setx WSLENV BASH_ENV/u
cmd.exe /C setx BASH_ENV /etc/bash.bashrc

Check the issues with systemd and snap in WSL here: