Cannot communicate with server


#1

Good morning. I’m trying to install Pycharm on my pc (it’s windows 10 but to do this I’m using the Ubuntu server and shell) , but the shell gives me this error when I run the code to install the programme: " error: cannot communicate with server: Post http://localhost/v2/snaps pycharm-community: dial unix /run/snapd.socket: connect: no such file or directory" .
When I type: “snap version”, the response is:" snap 2.34.2+18.04 snapd unavailable series - “.
Then I tried: " sudo apt install snapd” and the response is:" … snapd is already the newest version( (…)".
then: “systemctl status snapd.service” , response:“sytem has not been booted with systemd as init system (PID 1)”.
Finally : " journalctl -u snapd.service " , the response is: " No journal files were found. --No entries-- ".
What is the problem? What should I do and what do you suggest me? Lastly, my ubuntu shell isn’t able to perform copy and paste operations, neither text selection. Do you suggest me to uninstall and then install Ubuntu on my windows pc?
Thank in advance t anyone will try to help me.


#2

“system has not been booted with systemd as init system (PID 1)”

This is your problem. What Linux distribution are you running? Devuan by any chance?


#3

What does this mean? Do you mean you are using the Windows Subsystem for Linux?

If you did mean that you are using WSL then it won’t work, because the WSL does not contain the required functionality (namespaces et al) to support snaps and also does not run systemd which, as @popey points out above, also prevents snaps from working.

To be able to run snaps you need to run the real Linux kernel along with a distribution that contains systemd. This can be in a VM if you are running on Windows, such as VirtualBox.


#4

I’m running Ubuntu on Windows 10. Yes, I’m using WSL. Ok, I uderstood what is the problem (I think). So, do you suggest me to download VirtualBox and try? It is requested high level expertise to do this step? My purpose is to install pycharm.
Sorry for the inappropriate terminology :slight_smile: .
Thank you both, a lot!


#5

Yes, I’m using WSL. Ok, I uderstood what is the problem (I think). So, do you suggest me to download VirtualBox? Do I have to delete the Ubuntu application (the application which allow me to communicate with the ubuntu shell) before proceeding ?
Thank you very much!


#6

out of curiosity, what does uname -a print on WSL, these days?


#7

#8

Why can’t you simply install the Windows distribution of PyCharm?

Another reason that PyCharm snap won’t work under WSL is that it currently doesn’t support an X Window System, which prevents all programs with graphical interface from running.


#9

Now I’ve installed everything on Windows, finally I did it and it’ working. The person who is going to follow and help me in this project uses Ubuntu so we thought that could be good to have Ubuntu on my pc for better support. But then we changed our mind so finally I did the installation on windows.


#10

In that case a VM or baremetal dual-boot Ubuntu installation is recommended, especially when your friend doesn’t have a valid Windows license.