Cannot apply seccomp profile using hello-world


#1

Trying to setup snap on a different machine to test out a snap I made, but seems to be getting an error I dont know how to debug.

I get the same error with the hello-world snap, so its not related to my snap.

snap run hello-world
cannot apply seccomp profile: Invalid argument

Same error with sudo… and if I try to run --shell

Snap Core: 16-2.28.5
Ubuntu 16.04.3 LTS (GNU/Linux 4.4.38-v7+ armv7l)


#2

Hey, thanks for your report. How did you install the hello-world snap? What is the output of snap version ? And could you put the seccomp file somewhere please, the file is located in /var/lib/snapd/seccomp/bpf/snap.hello*.{bin,src}.


#3

snapversion
snap 2.28.5
snapd 2.28.5
series 16
ubuntu 16.04
kernel 4.4.38-v7+

There are like 4 sets / 8 files… you need all of them? or will just 1 set do?


#4

where did you get that kernel from ?
this is definitely not an ubuntu kernel and most likely missing some required seccomp config options …


#5

downloaded from here: https://ubuntu-mate.org/download/

did apt-get update/upgrade/dist-upgrade


#6

I have the files… how do I attach them or send?


#7

Can i email these files to someone?


#8

emailing anything wont help. your kernel simply does not have the right features enabled (looks like it is simply the raspberry-pi foundation kernel). you would need to use the linux-raspi2 kernel package from the ubuntu archive …