Can not install snap app

is there anyone can install mjpg-streamer ? i got this " error: snap “mjpg-streamer” not found", but i have installed “hello-world” app yesterday.
here is the app web:

What’s the architecture of your system? mjpg-streamer is not available for arm64, if this is your architecture you won’t be able to install until an arm64 build is available.

Check the result of snap info mjpg-streamer as well, it may tell you more.

thanks for your help! it is very kind of you !

i type “snap info mjpg-streamer” , then i still got this "error: no snap found for “mjpg-streamer”

Right, if the snap is not available for your architecture at all, snap info will show nothing.

All signs point to your system being arm64 (or in any case, not amd64, i386 or armhf, the only architectures for which this snap is built). To help confirm, could you please run uname -a and post the output?


Hi, i’m the owner of mjpeg-streamer and it indeed doesnt seem to build for arm64 for no apparent reason … (it has no specific architectures: entry in snapcraft.yaml or anything) … this seems to be a bug with any idea whats going on here ?

(source is at )

here is my system info

any suggestions?

thanks for your help.

I tried several other applications list at Snap search results for 'camera' — Linux software in the Snap Store ,with keyword “camera”, and i got the same result like "error:snap “XXX” not found.:pensive:

And i have no idea about whats going on :neutral_face:


@ogra arm64 builds were enabled by default on build service relatively recently. Remove your project and re-add it to build to fix this. The next build you trigger (which will happen when you re-add it, will have arm64 builds enabled.


This indicates we need to improve our UI here. We talked about showing something like:

$ snap info s390x-only
error: snap "s390x-only" is not available for your architecture

$ snap install s390x-only
error: snap "s390x-only" is not available for your architecture

Was there any announcement around this ? i think that would have made sense :slight_smile:

@ShengSiMeng i removed and re-added the build to and it now produces arm64 snaps as well … you should now be able to find mjpg-streamer in the store on your system.

1 Like

It is great to hear this! :smile:

Thanks for your works! “mjpg-streamer 2.0 from ‘ogra’ installed” appears on my screen and i am very excited!

We don’t have a blog for but it’s coming. This would be the kind of thing we could announce on it. Service changes, updates, bug fixes etc.

1 Like