Call for Testing: Tales of Maj'Eyal

Time for another game in the snap store, methinks.

Tales of Maj’Eyal (ToME) is a free, open source roguelike RPG, featuring tactical turn-based combat and advanced character building. Play as one of many unique races and classes in the lore-filled world of Eyal, exploring random dungeons, facing challenging battles, and developing characters with your own tailored mix of abilities and powers. With a modern graphical and customisable interface, intuitive mouse control, streamlined mechanics and deep, challenging combat, Tales of Maj’Eyal offers engaging roguelike gameplay for the 21st century.

The continent of Maj’Eyal lives in a relative peace. After millennia of war the orcs are extinct, the advanced races have allied together, and the evils of magic have been repressed. But there are still untamed forests, cursed lands, marauding bandits, sealed dungeons of undead, and whispers spread of hidden cults of mages. Some even say the orcs are not all dead, and muster their strength in dark places.

You are an adventurer, seeking your fortune in the open world, investigating ruins and mysteries in search of riches and powers. Explore a continent still scarred by the terrible Spellblaze from ages past, teeming with wild beasts, monsters, trolls and giants. Delve through dark dungeons infested by armies of undead, demonic monstrosities and hideous horrors. Uncover world changing secrets, from relics of the ancient and all-powerful Sher’Tul race to veiled cities of magic and concealed psionic beings. Fight with skill and care against undying necromancers, towering dragons, primeval forces, arcane demons and world-threatening powers.

Take part in an epic fantasy adventure like no other, engaging both your imagination and your intelligence, demanding thought and attention to succeed. Winner of the Roguelike of the Year award 2010, 2011 and 2012, Tales of Maj’Eyal is backed by constant development and an active, friendly community that have together invested over 945 years of total playtime.

I haven’t done much testing with this one. The game is huge and complex. It isn’t usually a style of game which appeals to me but it gets Overwhelmingly Positive reviews on Steam so I’m looking forward to trying it.

Let me know if it runs on your machine and post your combination of hardware and drivers. I’m particularly interested in whether the online integration works.

snap install talesofmajeyal



Killed by Prox on Trollmire 3… apparently this is usual for newbies… Apparently I should only get one level in something (can’t remember what…) and I should get Rush… Really cool that there’s in-game chat and online character profiles despite it being a single-player game!

This was really enjoyable, the graphics feel better ingame than they look in the screenshots! The snap worked flawlessly on my machine up until that point. Think this’ll have to be added to my list of great FOSS games.

Lenovo ThinkPad T430

$ snap version
snap    2.31~rc2 # (3978, candidate)
snapd   2.31~rc2
series  16
ubuntu  17.10
kernel  4.13.0-32-generic

talesofmajeyal 1.5.5 (1)

1 Like

That’s a great report. Thanks!

You’re welcome :slight_smile: Also, on my character page it’s listing me as having the Items Vault 1.5.0 but I haven’t bought the game or donated to it…so presumably it was bundled in the snap and needs to be removed? Unless this is a mistake in the game/character page itself…

Also I haven’t tried any mods etc, I wonder how they’ll work with the snap…

Also it would be good if you added a contact field to the entry with snap info talesofmajeyal, maybe an email or a link to this forum topic (until/unless the snap is taken on by upstream, then it can link to upstream support).

1 Like

I’m not sure about that. The only things in the snap are whatever is bundled in the source tarball from the official site. I’ll drop an email to upstream to clarify whether they mean for this to be distributed.

I’ll add some contact details as you suggest.

Thanks again!


The game is astounding, truly great. All action, all loot, no grinding and no fluff. Can’t find a single fault with it hitting all the buttons, great snap.


Great. Thanks for the report!

I’ve spent a few hours with it now and haven’t hit any issues. Do you think it is ready to promote to the “stable” channel?

Reading about the vault thing, I think everyone gets the vault item but you only get slots in the vault by donating. I’ll explore further.

1 Like

Yes, it’s definitely ready for promotion IMO.

1 Like

@mcphail I actually already installed this and it works well in Solus too :wink: !

1 Like

On Ubuntu I am unable to copy addon files to the ./snap/… /addons/ folder.
I get a read-only file system error.
It would be nice if there was a spot in my home folder where the config and save files are kept that teaa files would get used? I’m going to dig in the cfg files, maybe there’s a fix there. Addons make TOME better.

1 Like

It might be a few days before I can look at this but I’d like to get it working for you. I’ll ping you here when I’ve had the chance explore the problem, if that’s ok?

Sure. If the addon folder could be made into a setting/.cfg file it could work for different systems.

I think this works if you create a folder named addons under $HOME/snap/talesofmajeyal/current/.t-engine/4.0 . Do you want to test that and let me know if it works for you? If so, I’ll try to think of a way to make this more obvious to players.

1 Like

talesofmajeyal fails to run for me.

running /snap/bin/talesofmajeyal
I get this error
WebCore config: library(/snap/talesofmajeyal/29/ spawn(/snap/talesofmajeyal/29/cef3spawn)
Loading WebCore: Failed loading /snap/talesofmajeyal/29/ /snap/talesofmajeyal/29/ cannot open shared object file: No such file or directory
[CPU] Detected 8 CPUs
OpenAL device available: OpenAL Soft (default OpenAL Soft)
Available video driver: x11
Available video driver: mir
Available video driver: wayland
Available video driver: dummy
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
NO SELFEXE: bootstrapping from CWD
Creating save thread
===top 2
Booting T-Engine from: /snap/talesofmajeyal/29/t-engine
SelfExe gave us app directory of: /snap/talesofmajeyal/29/
LuaVM: LuaJIT 2.0.2 x64
Creating particles thread 0
Creating particles thread 1
Creating particles thread 2
Creating particles thread 3
Creating particles thread 4
Creating particles thread 5
Creating particles thread 6
[DO RESIZE] Requested: 800x600 (0, 0); zoom 100%
LuaVM: LuaJIT 2.0.2 x64
error opening screen: Couldn’t find matching GLX visual
LuaVM: LuaJIT 2.0.2 x64
LuaVM: LuaJIT 2.0.2 x64
LuaVM: LuaJIT 2.0.2 x64
LuaVM: LuaJIT 2.0.2 x64
LuaVM: LuaJIT 2.0.2 x64
LuaVM: LuaJIT 2.0.2 x64
AL lib: (EE) alc_cleanup: 1 device not closed

Here are the details of my setup
snap 2.35.4
snapd 2.35.4
series 16
debian -
kernel 4.18.0-2-amd64
libglx-mesa0:amd64 18.1.7-1

nVidia GeForce 9600GT
driver: nvidia proprietary 340.107
nvidia-legacy-340xx-driver 340.107-2 amd64 NVIDIA metapackage (340xx legacy version)

Files doesn’t exist anywhere on my system

libGl snap
-rw-r–r-- 1 root root 471680 Jun 14 12:31 /snap/talesofmajeyal/29/usr/lib/x86_64-linux-gnu/mesa/

libGl debian install
installed version libgl1-nvidia-legacy-340xx-glx:amd64 340.107-2 amd64 NVIDIA binary OpenGL/GLX library (340xx legacy version)

lrwxrwxrwx 1 root root      14 Aug 10 05:50 /usr/lib/mesa-diverted/x86_64-linux-gnu/ ->
lrwxrwxrwx 1 root root      14 Aug 10 05:50 /usr/lib/mesa-diverted/x86_64-linux-gnu/ ->
-rw-r--r-- 1 root root  596296 Aug 10 05:50 /usr/lib/mesa-diverted/x86_64-linux-gnu/
lrwxrwxrwx 1 root root      48 Feb 16  2016 /usr/lib/x86_64-linux-gnu/ -> /etc/alternatives/
lrwxrwxrwx 1 root root      50 Jan 28  2018 /usr/lib/x86_64-linux-gnu/ -> /etc/alternatives/
lrwxrwxrwx 1 root root      16 Jan 30  2018 /usr/lib/x86_64-linux-gnu/nvidia/legacy-304xx/ ->
-rw-r--r-- 1 root root 1076560 Sep 14  2017 /usr/lib/x86_64-linux-gnu/nvidia/legacy-304xx/
lrwxrwxrwx 1 root root      16 Jul  4 17:00 /usr/lib/x86_64-linux-gnu/nvidia/legacy-340xx/ ->
-rw-r--r-- 1 root root 1267800 May 24 22:40 /usr/lib/x86_64-linux-gnu/nvidia/legacy-340xx/
lrwxrwxrwx 1 root root      53 Jan 27  2018 /usr/lib/x86_64-linux-gnu/nvidia/ -> /etc/alternatives/

That’s all i can think of.

This worked for me. As soon as I entered the game the addon appeared on the active addons list.

1 Like

Brilliant! good to know.