Call for testing: Postman


#1

Postman is a tool for API development https://www.getpostman.com/

 snap install postman

The postman snap name has been registered for a while now but nothing has happened there so far, so I decided to try this on my own, since I use the tool myself anyway.

EDIT: The ‘postman’ snap name has been transferred and the snap can now be installed just by

 snap install postman

Classic confinement for Postman
#2

Thanks! I too use it often so I might give this a test-drive :+1:


#3

It’s working wonderfully here. Thank you, @junglerobba.


#4

@evan Thanks for testing.
I saw that you’re on the Snapcrafters admin list, so I figured I’d just ask here:
Would the correct next step be transferring the snap to snapcrafters? Or should I try to get in contact with the Postman team?


#5

@junglerobba Thanks for working on Postman, works great here :slight_smile: I know friends of mine who are very keen to see a snap of this!

I have tried to contact upstream before and had no reply. My suggestions are this:

  • Register postman and publish the snap under that name.
  • Make sure the executable is not name spaced, so it is it just postman from the terminal.
  • Unpublish postman-unofficial so no else can discover it.
  • You reach out to Postman upstream (pull requests work best :wink: ) and encourage them to take on ownership of the Postman snap.
    • We can assist you with this, I’ll send you a PM.

How does that sound?


#6

Sounds great!

postman is already registered though, can I link this thread in the request?


#7

I’m getting this error while trying to install:

image


#8

@brianop I had already set the snap to private while waiting for the registration of the new name. I made it public again so the install should work now


#9

I just installed and everything seems to be fine. Thank you once again!


#10

@Wimpress Any update on this? I already tried to register the Postman snap and put in a link to this thread for the dispute, that has been open for two weeks now though.


#11

@junglerobba, have you tried PMing @Wimpress about it?


#12

Just tried this on Ubuntu 17.10 - I get Segmentation fault (core dumped) upon launching it.

The “official” Postman launches fine on the same machine.

Please let me know if there’s anything I can provide that may be of help.


#13

My apologies, downloaded the latest version of Postman and that is having the same issue!


#14

Yesterday postman was working fine, I’ve used this snap for about a month now on Ubuntu 18, today postman didn’t launch anymore and when using “postman” in a terminal I get the following error:

Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"


#
# Fatal error in ../../v8/src/snapshot/snapshot.h, line 28
# Check failed: IsSane().
#

==== C stack trace ===============================

    libnode.so(+0xb8f72e) [0x7f231347f72e]
    libnode.so(V8_Fatal+0xdf) [0x7f231347ef5f]
    libnode.so(+0x6098ad) [0x7f2312ef98ad]
    libnode.so(v8::Isolate::New(v8::Isolate::CreateParams const&)+0x15b) [0x7f23130c282b]
    /snap/postman/81/usr/share/Postman/Postman() [0x2a8d51b]
    /snap/postman/81/usr/share/Postman/Postman() [0x2a8d425]
    /snap/postman/81/usr/share/Postman/Postman(atom::JavascriptEnvironment::JavascriptEnvironment()+0x31) [0x3713c11]
    /snap/postman/81/usr/share/Postman/Postman(atom::AtomBrowserMainParts::PostEarlyInitialization()+0xdf) [0x370eeaf]
    /snap/postman/81/usr/share/Postman/Postman() [0x24952ce]
    /snap/postman/81/usr/share/Postman/Postman() [0x2581a0d]
    /snap/postman/81/usr/share/Postman/Postman() [0x2693b6d]
    /snap/postman/81/usr/share/Postman/Postman() [0x23d7342]
    /snap/postman/81/usr/share/Postman/Postman() [0x1c23f85]
    /snap/postman/81/usr/share/Postman/Postman() [0x23d75a2]
    /snap/postman/81/usr/share/Postman/Postman(main+0x88) [0x3706dc8]
    /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f230b994830]
    /snap/postman/81/usr/share/Postman/Postman() [0x513f39]
Illegal instruction (core dumped)

What is going on?