Call for testing: notepad-plus-plus


#27

Edit: This post was eventually edited. Please see the next post for information.

Thanks for your response. Here are the info you asked:

snap run --shell notepad-plus-plus
locale

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE=“en_US.UTF-8”
LC_NUMERIC=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=nl_NL.UTF-8
LC_NAME=nl_NL.UTF-8
LC_ADDRESS=nl_NL.UTF-8
LC_TELEPHONE=nl_NL.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8
LC_IDENTIFICATION=nl_NL.UTF-8
LC_ALL=


#28

thanks you can now edit post and remove other infos only leave locale one and can you also post locale from snap shell.

snap run --shell notepad-plus-plus
locale


#29

Thanks. I tried to do what you asked, but I’m not sure if that’s what you wanted. Because, I’m not really an experienced Linux user and it threw three lines of messages at the top of the output when I tried your commands. I didn’t know where should I set the directory. I tried to set it /snap/notepad-plus-plus, and run locale from there, but it gave me same message.


#30

It shouldn’t matter as the locale command is provided by the core snap.

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=zh_TW.UTF-8
LANGUAGE=zh_TW:zh_CN:en_US:zh_TW:zh_CN
LC_CTYPE="zh_TW.UTF-8"
LC_NUMERIC="zh_TW.UTF-8"
LC_TIME="zh_TW.UTF-8"
LC_COLLATE="zh_TW.UTF-8"
LC_MONETARY="zh_TW.UTF-8"
LC_MESSAGES="zh_TW.UTF-8"
LC_PAPER="zh_TW.UTF-8"
LC_NAME="zh_TW.UTF-8"
LC_ADDRESS="zh_TW.UTF-8"
LC_TELEPHONE="zh_TW.UTF-8"
LC_MEASUREMENT="zh_TW.UTF-8"
LC_IDENTIFICATION="zh_TW.UTF-8"
LC_ALL=

#31

hi, thanks a lot for all your works on this snap! it really help.

When i use it daily, it’s found that i couldn’t enter chinese in NPP with chinese input method. Is there anyone can help me out? Thanks a lot in advance.


#32

Currently, only iBus input method framework is confirmed compatible with snapd, and requires the snap maintainer to assert desktop-legacy interface and using the desktop-launch launcher in ubuntu/snapcraft-desktop-helpers


#33

Thanks for your reply!

But unfortunately i’m using Fcitx, so is there any plan for snap NPP to support Fcitx?


#34

Thank for your work. But I run into two problems.

  1. After set to hide the menu bar, I can’t access to menu bar again. Alt/Alt+t/F10/F11/F12 can’t work.
    Reinstalling notepad-plus-plus can resove this problem.

  2. The font size of menu bar is quite too small.
    Cope my WINE file can resolve this problem, I mean:
    cp ~/.wine/user.reg ~/snap/notepad-plus-plus/common/.wine

But please note that I had configurated WINE by increasing pdi. I don’t known how to set snap’s WINE.

3)There’s no Plugin menu in menu bar.


#35
  1. it is wine issue as I can reproduce same issue on system install wine so better report it to winehq.
    you can restore menu by editing config.xml then changing value of menubar from hide to show.

  2. you can run winecfg like this notepad-plus-plus winecfg then change the dpi from graphics tab.

  3. recent change in npp setup introduce change to plugins location caused this as I have identified it and hopefully should be fixed in next revision.


#36

Thank you for your reply.

I tried to change value of menubar from hide to show, but it is overided by notepad++. OK, maybe I’d better report this bug to winehq.


#37

I found a bug report in Bug Tracking Database of winehq, this bug is reported in 2010.
https://bugs.winehq.org/show_bug.cgi?id=21918


#38

I agree with you! The more popular apps that can be used on Linux distros, the more likely people will be willing to switch to GNU/Linux. The lure of free and open source was what initially got my attention. Now that I am getting into it more, the more I doubt I will use any other OS on my personal devices.


#39

Pushed snap revision now it should fix plugin issue. Too bad the patch fix did not make it to wine to solve menu bar issue.


#40

cannot install “notepad-plus-plus”: Post
https://api.snapcraft.io/v2/snaps/refresh: proxyconnect tcp: tls:
oversized record received with length 20527
Iam getting this issue while executing " sudo snap install notepad-plus-plus" command.


#41

Nothing to do with this snap: your issue is a bad proxy setting, as per


#42

Is there a known issue with unix dot-files? (filenames beginning with a period). I don’t expect to see them listed in the Open menu but, when I explicitly try to open one, I see error message:

Cannot open file “Z:\home\flymike\.wget.hsts”

I do have read/write permission on the file.

How can I find further diagnostic information on this error?


#43

dot files in the root of your home folder and explicitly denied to snaps to prevent malicious snaps from reading sensitive data. If you move the file to not have a . in front of it or move it to a subdirectory that doesn’t start with a . then you should be able to edit it.

Also, I see that the the file you posted doesn’t start with a .

For further information, you can check the journal with

journalctl -e --no-pager | grep DENIED

which should show the apparmor denial for the notepad-plus-plus snap trying to access that file.


#44

Thanks for the explanation.
So, I think you’re saying this is a restriction of snaps in general, and not particular to notepad++. Right?
BTW the dot wasn’t visible because I originally failed to escape the escape character (backslash) preceding it.


#45

Yes that restriction is not particular to notepad++. The only exception is if the snap author uses a personal-files interface, which will only grant access to specific dotfiles, such as a AWS snap might use the personal-files interface to access specifically $HOME/.aws/...


#46

Hello, @mmtrt ! Your programs are amazing! I and my teacher develop a small program writted on C# with Windows Forms and now we want to port it to GNU/Linux via WINE. Please, say me how you port your programs by this way.
P.S. See our FLOSS project here: https://gitlab.com/pozharovartyom/securities
Thanks in advance!