Call for testing: Mumble Snap


#1

Thanks to @bashfulrobot for working on a Mumble snap, it’s now in the store candidate channel, ready for testing!

Mumble is a popular low latency VOIP client.

How to install

snap install mumble --candidate

How to run

Search for the familiar Mumble icon in your desktop launcher, or snap run mumble or /snap/bin/mumble.

mumble_256

Requested setups

I’ve done some basic testing on Ubuntu 17.10 but I’m not an audio expert so can’t necessarily tell if the audio quality is as expected, or that all possible codecs are supported.

I’m also keen to hear feedback about

  • Using the snap on older releases
  • Connecting to different Mumble servers, which use a variety of codecs and sample rates
  • Selecting the correct input and output devices
  • Setting and using the push-to-talk
  • Configuring and using voice activated audio

If you are already a Mumble user, then you can copy your host Mumble config into the snap directory in order to have your favourites all setup. Something like this one-off:-

sudo snap install mumble --candidate
mkdir -p ~/snap/mumble/current/.config
cp -a ~/.config/Mumble ~/snap/mumble/current/.config
cp -a ~/.local/share/data/Mumble/Mumble ~/snap/mumble/current/.local/share/data/Mumble
snap run mumble

Reporting feedback

Please report any issues with the snap on this thread, here on the forum.


#2

err VPN warning here, pal.

but cheers.


#3

Successfully installed, started, and run through the setup wizard.


#4

I don’t understand what you’re saying here. Please elaborate


#5

I have it installed. Full-blown test coming Tuesday @popey . :grin:


#6

Thanks for testing! I also tested thoroughly with @Wimpress for a day or so, and it all seems okay, so I have pushed 1.2.9 to the stable channel.

I have also hooked up the dev builds of 1.3.0 to the edge channel. It looks a bit different. Feel free to test that out! :smiley:

It also has a dark theme!


#7

Hi Popey,

the mumble snap does not start on Ubuntu 17.10.
The shell spits out an error message: “desktop-file did not state an exec-field” (rough translation).

It works from terminal.

mumble

mumble 1.2.19 8 snapcrafters -


#8

Hmm. Ok. Will look into that. Thank you!


#9

I just tried to replicate here. I was able to run on 17.10 without issue,

mumble                   1.2.19              8     snapcrafters   -

Granted you may have fixed in the time since your reply.


#10

It works now.

I had to remove all snaps including snapd beforehand.
Seems like the problem was on my side.

Thanks for your help!


#11

Hi @popey & @bashfulrobot,
I’ve installed the mumble snap on Ubuntu 18.04.1 and I seem to get the same error as laryllan did, but am unhappy with his solution of uninstalling everything. To reiterate when I launch mumble I get a notification error saying;

desktop file didn’t specify Exec field

Now this may be an error in how I’ve set up snaps, or more accurately how I’ve not set them up as I’ve not done anything other than “snap install”, but other snaps work fine so I suspect it’s specific to this Mumble package.

Let me know what other info you require to understand the issue better. For now I’ll dump the snap info for the package and ubuntu install details here;

$ snap info mumble
name: mumble
summary: Mumble is an open source, low-latency, high quality voice chat software.
publisher: snapcrafters
license: unknown
description: |
Mumble is a voice chat application for groups. While it can be used for any
kind of activity, it is primarily intended for gaming. It can be compared
to programs like Ventrilo or TeamSpeak. People tend to simplify things, so
when they talk about Mumble they either talk about “Mumble” the client
application or about “Mumble & Murmur” the whole voice chat application suite.
commands:
mumble
snap-id: wVB1RfBgsZY8dmVifSFeMkTE6UN41osI
tracking: stable
refresh-date: today at 08:39 BST
channels:
stable: 1.2.19 (8) 86MB -
candidate: ↑
beta: ↑
edge: 1.3.0-dev (97) 118MB -
installed: 1.2.19 (8) 86MB -

$ ubuntu-report
{
“Version”: “18.04”,
“OEM”: {
“Vendor”: “Entroware”,
“Product”: “Orion”
},
“BIOS”: {
“Vendor”: “American Megatrends Inc.”,
“Version”: “1.05.04E”
},
“CPU”: {
“OpMode”: “32-bit, 64-bit”,
“CPUs”: “8”,
“Threads”: “2”,
“Cores”: “4”,
“Sockets”: “1”,
“Vendor”: “GenuineIntel”,
“Family”: “6”,
“Model”: “142”,
“Stepping”: “10”,
“Name”: “Intel® Core™ i5-8250U CPU @ 1.60GHz”,
“Virtualization”: “VT-x”
},
“Arch”: “amd64”,
“GPU”: [
{
“Vendor”: “8086”,
“Model”: “5917”
}
],
“RAM”: 16.3,
“Partitions”: [
114.3,
0.5
],
“Screens”: [
{
“Size”: “309mmx174mm”,
“Resolution”: “1920x1080”,
“Frequency”: “60.02”
},
{
“Size”: “531mmx299mm”,
“Resolution”: “1920x1080”,
“Frequency”: “60.00”
}
],
“Autologin”: true,
“LivePatch”: false,
“Session”: {
“DE”: “ubuntu:GNOME”,
“Name”: “ubuntu”,
“Type”: “x11”
},
“Language”: “en_GB”,
“Timezone”: “Europe/London”,
“Install”: {
“Media”: “Ubuntu 18.04.1 LTS “Bionic Beaver” - Release amd64 (20180725)”,
“Type”: “GTK”,
“OEM”: false,
“PartitionMethod”: “use_device”,
“DownloadUpdates”: true,
“Language”: “en”,
“Minimal”: true,
“RestrictedAddons”: true,
“Stages”: {
“0”: “language”,
“7”: “console_setup”,
“10”: “console_setup”,
“12”: “prepare”,
“29”: “partman”,
“60”: “partman”,
“65”: “start_install”,
“94”: “timezone”,
“96”: “usersetup”,
“114”: “user_done”,
“461”: “done”
}
}
}


#12

Can you try the version from edge? I think this problem is fixed there.


#13

I just did a fresh install on 18.04.1 and had no issues. I am just rebooting to see if that changes anything.


#14

I should have mentioned I have a dual screen setup with laptop and monitor which now I think about it may be the issue. I’m not at home to test what happens with one screen, but will come back to this thread once I have.

Also will comment on the above suggestion from the podcasting troll @willcooke :wink:


#15

Thanks for identifying the issue with launching. Apologies for not getting to this sooner, I’ve been away at events which has sucked a lot of my time recently.

Mumble is a tricky one. The yaml in snapcrafters builds only the new 1.3-dev branch which has moved on quite a lot from the old 1.2 stable mumble build. I think what I’ll do is duplicate it so we get two sets of builds - stable 1.2 builds which allow us to support those stable releases, and another 1.3-dev branch to build those.

In the process I’ll fix the launching issue @jesse identified.


#16

Ok, new builds in the candidate channel. Anyone who sees the issue @jesse saw (missing icon / desktop launcher) - please snap refresh mumble --candidate or snap install mumble --channel=candidate if you removed it. Let me know if this fixes it. If it does, I’ll promote to stable.


#17

Thanks @popey, using the candidate channel fixed it for me.


#18

Awesome, thanks for confirming. I have pushed to stable!


#19

Just so I’m sure, now I;
snap refresh mumble --stable ??


#20

Exactly. Do that and you’ll only get stable releases from now on. Currently candidate = stable, but that may change as time goes on.