Call for testing: Mailspring


#21

Ubuntu’s default GNOME session in Ubuntu 17.10. Tiling works fine with other applications.


#22

Works fine here on 17.10 with Super+Left and Super+Right (and Super+Up and Super+Down for maximise and restore)


#23

I’m trying here with Super+Left and Super+Right but no luck, have you tried the Wayland session (that may be the issue here, not sure)?


#24

I’m getting this denial CC @jdstrand

lis 20 16:33:58 fyke dbus[2598]: apparmor="DENIED" operation="dbus_signal"  bus="session" path="/org/freedesktop/Notifications" interface="org.freedesktop.Notifications" member="ActionInvoked" name=":1.17" mask="receive" pid=12601 label="snap.mailspring.mailspring" peer_pid=2667 peer_label="unconfined"

Is this something that we should have the desktop interface provide?


#25

Works under wayland and x here.


#26

One of desktop or desktop-legacy, yes. I’ve taken a TODO to add this as part of the next policy updates PR.


#27

Same here, the mouse pointer doesn’t scale correctly. While on my desktop I can see it normally, over Mailspring shows it ridiculously small. Other snaps (like the Gradio one https://snapcraft.io/gradio/ ) scales it correctly.

It would be posible to correct it, please?


#28

https://github.com/snapcore/snapd/pull/4359 as the ActionInvoked fix.


#29

I am using the mailspring snap on Solus. It worked fine at the beginning. Since some days the snap stopped working and responses with the error shown in the screenshot.

mailspring


#30

Can’t seem to get the option for running mailspring on startup. Was the option removed??:thinking::thinking:


#31

On first launch, after logging in with my mailspring details and trying to add a gmail account I get this:

jamie@ubik:~$ mailspring
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"
Streaming log data to /run/user/1000/snap.mailspring/Mailspring-12840.log
App load time: 1211ms
Error org.freedesktop.DBus.Error.UnknownInterface: Object does not implement the interface
Error org.freedesktop.DBus.Error.ServiceUnknown: The name com.canonical.SafeLauncher was not provided by any .service files

On the sign in with Google in your browser window.

Manually using the supplied url works.


#32

I also cannot send mail. Setting up just one Gmail account and trying to send an email, no tweaking or other changes, results in:

This is with:

jamie@ubik:~$ snap --version
snap    2.30~rc3
snapd   2.30~rc3
series  16
ubuntu  17.10
kernel  4.13.0-19-generic

#33

It’s a design issue/bug with snappy, see Browser not setting itself as the default


#34

Hi.

On Solus, I recently get the following error (it did work previously):

Noto-Sans IS installed on my system, but I don’t know if the snap can access it (doesn’t seem so).
Shouldn’t the mailspring snap include all necessary libraries, thus shipping the fonts too?

Greetings,
ahahn94


#35

doesn’t even start on Solus :frowning:


#36

I use Startup Applications, works, but as you point out is not automatic.


#37

Well that’s really unfortunate. The deb version had the option of setting
up launching on startup from within the app.


#38

so the NerdZoom community has found a “fix”. We’ve all managed to start the snap on Solus after uninstalling mailspring snap, removing the mailspring folder and reinstalling. So we don’t know what broke it and why it wasn’t fixed by an update but so far mailspring runs great.


#39

Works for me now.

I’ve noticed that notifications come up on the GNOME lock screen as from ‘Electron’ rather than ‘Mailspring’, is this a bug in Electron, Mailspring, or snappy (if the bug doesn’t exist in the Deb (does it? or does it not?) then presumably it’s a bug in snappy)?

$ snap version
snap    2.30
snapd   2.30
series  16
ubuntu  17.10
kernel  4.13.0-21-generic

#40

OK scratch that - ran it using snap run mailspring…

for the record it did not copy its .desktop launcher into the right place in

/usr/share/applications/