Call for testing: Mailspring

https://github.com/snapcore/snapd/pull/4359 as the ActionInvoked fix.

I am using the mailspring snap on Solus. It worked fine at the beginning. Since some days the snap stopped working and responses with the error shown in the screenshot.

mailspring

Can’t seem to get the option for running mailspring on startup. Was the option removed??:thinking::thinking:

On first launch, after logging in with my mailspring details and trying to add a gmail account I get this:

jamie@ubik:~$ mailspring
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"
Streaming log data to /run/user/1000/snap.mailspring/Mailspring-12840.log
App load time: 1211ms
Error org.freedesktop.DBus.Error.UnknownInterface: Object does not implement the interface
Error org.freedesktop.DBus.Error.ServiceUnknown: The name com.canonical.SafeLauncher was not provided by any .service files

On the sign in with Google in your browser window.

Manually using the supplied url works.

I also cannot send mail. Setting up just one Gmail account and trying to send an email, no tweaking or other changes, results in:

This is with:

jamie@ubik:~$ snap --version
snap    2.30~rc3
snapd   2.30~rc3
series  16
ubuntu  17.10
kernel  4.13.0-19-generic

It’s a design issue/bug with snappy, see Browser not setting itself as the default

Hi.

On Solus, I recently get the following error (it did work previously):

Noto-Sans IS installed on my system, but I don’t know if the snap can access it (doesn’t seem so).
Shouldn’t the mailspring snap include all necessary libraries, thus shipping the fonts too?

Greetings,
ahahn94

doesn’t even start on Solus :frowning:

I use Startup Applications, works, but as you point out is not automatic.

Well that’s really unfortunate. The deb version had the option of setting
up launching on startup from within the app.

1 Like

so the NerdZoom community has found a “fix”. We’ve all managed to start the snap on Solus after uninstalling mailspring snap, removing the mailspring folder and reinstalling. So we don’t know what broke it and why it wasn’t fixed by an update but so far mailspring runs great.

1 Like

Works for me now.

I’ve noticed that notifications come up on the GNOME lock screen as from ‘Electron’ rather than ‘Mailspring’, is this a bug in Electron, Mailspring, or snappy (if the bug doesn’t exist in the Deb (does it? or does it not?) then presumably it’s a bug in snappy)?

$ snap version
snap    2.30
snapd   2.30
series  16
ubuntu  17.10
kernel  4.13.0-21-generic

OK scratch that - ran it using snap run mailspring…

for the record it did not copy its .desktop launcher into the right place in

/usr/share/applications/

snap desktop files go into /var/lib/snapd/desktop/applications/

(and that path is added to the systems search path for .desktop files usually)

If it doesn’t then there’s a bug which needs reporting.

1 Like

Hi, the app is really nice but a few problems here.

First, there is no icon for the snap on my side. Also, there seems to be several random visual artifacts every time I view a mail. For example,

When running I always get the error Gtk-Message: Failed to load module "canberra-gtk-module" even after installing libcanberra-gtk-module but not really sure if that’s the cause of the problems.

I’m on Kubuntu and the snap link here https://getmailspring.com/download failed to be recognised.
Installing the .deb worked OK. But Mailspring fails to start with the password management error described here:
https://foundry376.zendesk.com/hc/en-us/articles/115001875571 but the suggested libsecret is unknown in Discovery. I’m unsure about installing random stuff. The other email clients don’t need that.

The deb package works fine for me, however.

Just had an interesting bug, which I’m not sure how to confirm. During the application startup, there was a notification window with a progress bar with a message about “email database optimization,” which was all well and good. However, the shell was blocking all inputs, window updates, effectively everything but cursor redraws intermittently for seconds at a time.

On 17.10, GNOME3, X11 session.

After several weeks of usage on Kubuntu 16.04 and 16.10 everything works fine so far.

2 Likes