Call for testing: libreoffice 5.4.2

Call for testing: libreoffice 5.4.2


LibreOffice is a free and open source office suite, developed by The Document Foundation. The LibreOffice suite comprises programs for word processing, the creation and editing of spreadsheets, slideshows, diagrams and drawings, working with databases, and composing mathematical formulae.


How to install

snap install libreoffice --candidate

Note that the snap can coexist with the ubuntu packages. If you wish to remove the ubuntu packages to use solely the snap, you can do:

sudo apt remove “libreoffice*”
sudo apt autoremove

Requested Setups

At the moment that version of the snap is available for amd64 processors only. It is expected to work on any linux distribution that supports snaps, including on Wayland where previously it didn’t work.


This revision contains more languages (Japanese and Chinese/Taiwan were added), more fonts (see note below) and dictionaries for spellchecking, hyphenation and thesauri.
As a consequence the size of the snap has increased quite a bit. When snapd 2.29 is out, the use of the desktop interface means fonts from the host system will be exposed to the snap, so a lot of overhead can be removed, and the size should decrease substantially.

Specific Tests

I’m interested in your feedback on any tasks you perform using all the apps in the libreoffice suite.
Please report any issues you encounter in this thread. Thanks!

1 Like

Theming has regressed.

LibreOffice (21)

LibreOffice (37)

The first screenshot in each group is what matters most, since the rest are of the NotebookBar which is an experimental feature.

$ snap version
snap    2.28.5+17.10
snapd   2.28.5+17.10
series  16
ubuntu  17.10
kernel  4.13.0-16-generic

It’s generally good but the confinement still prevents it from accessing documents on network shares, USB drives or simply documents owned by another user. I’m afraid this basically disqualifies it. Perhaps libreoffice should switch to classic confinement, which would solve these limitations?

@jzimm if You mount USB devices under /media and connect the snap to removable-media, You will be able to access the documents.

the snap doesn’t allow to change input method to a Japanese one.
I’m using fcitx and mozc. My usual shortcut for toggling the japanese input doesn’t work

[feature request]
Please add Polish language spellchecking

[feature request]
Please add Japanese language spellchecking

[feature request]
Please enable the connection to removable-media by default without user intervention

Good catch! I had a custom config on my laptop which hid the regression. Looking into it now.

I have filed bug #1728708 to track that issue.

Added, and triggered a new build.

According to the libreoffice wiki, Japanese support doesn’t include spellchecking.

Started a new thread to request it.

1 Like

This is happening only on Ubuntu 17.10 (Artful Aardvark), where ~/.config/dconf/user doesn’t get created at login. I’ve filed bug #1728713 to track the issue.
Given that 17.04 and earlier releases are not affected, I won’t block the promotion of the snap on this.

@v1kn Yes but that doesn’t solve the problem of network shared folders, or not being able to open a document owned by someone else.

@oSoMoN Thanks for Your work.

Would you mind filing a bug to describe and track the issue with network shared folders (including what’s your setup for shared folders, what you expect to work, and how it doesn’t)?

Can you elaborate on how you expect to be able to open a document owned by someone else? Would that be in someone else’s home directory? Or owned by someone else in your home directory?


I already raised it as bug 109296 some time ago, the response was that it couldn’t be solved using the snap interfaces available, which AFAIK is indeed the case.

Specifically the default confinement doesn’t allow LO to access anything under /run/user/<uid>/gvfs/..... That’s why I believe that it would be appropriate for LO to use classic confinement at least until suitable interfaces become available.

Re opening documents owned by someone else: it can be indeed by browsing to another user’s directory, or by having a common directory with documents accessible to multiple people, or, in my case, it happens when I use an unprivileged LXC container to run a script that generates a DOCX file in my home, which is bind-mounted in the container.

Generally speaking: I believe that the classic confinement is adequate for apps that are basically little more than internet clients, but something like LO is and should be expected to be able to work with the full range of facilities offered by the OS.


I’m very happy!

This version fixes a bug I reported (Multiple users and groups in snaps) that prevented the installation from completing when the user and group were obtained from AD by the SSSD service.

In addition, filenames in Brazilian Portuguese are presented correctly.

Everything seems to work correctly, just a few messages on the console and an IO error.

modolo@gsat019046:~$ snap run libreoffice
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(soffice:5781): GLib-GIO-WARNING **: Error creating IO channel for /proc/self/mountinfo: Permission denied (g-file-error-quark, 2)
Failed to open config file '/build/libreoffice/parts/libreoffice/install/usr/share/libexttextcat/fpdb.conf'
Failed to open config file '/build/libreoffice/parts/libreoffice/install/usr/share/libexttextcat/fpdb.conf'
Failed to open config file '/build/libreoffice/parts/libreoffice/install/usr/share/libexttextcat/fpdb.conf'

Marcelo Módolo

Does presentation mode work now, with two displays, one acting as the presenter notes view and the other displaying the presentation itself?

This is almost always noise. It is specifically not required by the GTK file dialog and glib will fallback to sensible defaults. Note there was an error creating the IO channel, but the message is actually a warning.

I just noticed that on Ubuntu 17.10, amd64 with Wayland, window decorations are broken (only a close icon is shown, no minimise or maximise icons). I didn’t have a chance to test in other configurations yet.

In my tests it does. Your feedback welcome in case it doesn’t work for you.

Can you please refresh from the candidate channel and let me know if the issue is still there? If so, can you please attach a screenshot?

snap refresh libreoffice --candidate

This is now fixed in the candidate channel.

1 Like

I refreshed to rel. 41 this morning and I confirm that the problem seems to be solved. Thanks!