Call for Testing: LambdaRogue: The Book of Stars


#1

Hello all,

I think my snap (of my roguelike role playing game) is now working, but I keep it in development confinement until I can confirm it is really working.

It is available for testing here:

Install it with

sudo snap install --devmode lambdarogue --beta

If all is working well, you should be able to start the game either by clicking its icon or by entering “lambdarogue” in a terminal. When the game starts, you should see a window with a title screen and hear some music. (Additionally, a terminal window will open – that’s because the game can also be played in console mode on a 80x25 terminal, if set in the options).

To test if config and save games are created correctly, please try the following:

  1. Start a new game by pressing 1, enter a name, select coffeebreak mode, let the game give you a random character. You should see the main view then.

  2. Press ESC to go to the menu, then quit.

  3. Start the game again, press 1 again - you should see the name of your previously created character there. Select it by pressing “a”. If it loads correctly, the snap is working.

Thanks!


#2
$ sudo snap install lambdarogue --beta --devmode
lambdarogue (beta) 1.7.0 from Mario Donick (mariodonick) installed
$ lambdarogue 
ALSA lib conf.c:3916:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
                    ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM default
                                        Error: SDL Mixer could not be initialized.

#3

Oh. I totally did not think about the issue that ALSA hardcodes its path to its config files during build time… and ALSA is needed by SDL Mixer.

There seem to be some (rather complicated) solutions to this issue, which I have to check out.

Thanks for testing!


#4

Maybe using alsa interface will help, although I see it is not connected by default.


#6

Can you check in a terminal if it’s the same ALSA issue as with abitrolly? Thanks!


#8

No problem. From your Ubuntu apps menu, start the Terminal (it’s a black icon, usually).

Then type “lambdarogue” and hit enter. If any error message appears, just paste it here.


#9

I released a new test revision just now.

I have checked some other gaming snaps how their yaml file is configured. I then have added “libasound2” to the stage packages. Let’s see if this does the trick…


#11

Okay, according from your screenshot, the game does start. Both the console window and the game’s window are visible. (Ignore the libpng warnings).

If referring to the game itself (not the snap): Depends if you like traditional roguelikes with simple tile-based graphics :wink:

But the snap itself seems to be working (now) for you, which is great.


#13

Oh, I see. I have forgotten to include the category “Games” in the snap’s desktop file… added that right now.

If you would be willing to try again, I’d be very happy.


#15

Hm, the icon does appear for me now in the Games menu (using Gnome 3 on Ubuntu 18.04, ClassicMenu Indicator).


#16

Seems to work fine here. Game installs, saves work, sound works and the icon is added under the “Games” category.

(KDE Neon, nvidia graphics card running the proprietary 396 drivers)

Good stuff! Thanks for making this.


#17

I get this on my Ubuntu 18.04, nVidia equipped machine. 390 binary nVidia driver. I have 3 displays attached in case that matters.

$ lambdarogue
An unhandled exception occurred at $00000000005809AD:
EInOutError: Invalid input
$00000000005809AD

#19

Interesting… if you have the time, could you test the non-snap version of the game and tell me if you get the same error? (https://mariodonick.itch.io/lambdarogue-the-book-of-stars) Thanks!


#20

Thanks for testing, glad it works!


#21

Abitrolly, could you test the latest version, please?


#22

FWIW the game works fine on my Intel laptop. I suspect this may be weirdness on my nVidia machine.


#24

The “real agenda” is to get more exposure of my game using the snap store. And according to the snapcraft website, this is one reason why one should use snaps. At least that is how snapcraft is advertising for using snaps. I apologize if links to other sites are unwanted.

However, if an error message occurs where it is unclear if it is caused by the binary itself, or by my snap, I of course want to check this, and the easiest way for that is to link to the place where one can get the non-snap version.


#25

to give another data point, it runs fine on my 16.04 triple head setup with nvidia and the 384 binary driver … (same as popeys but one LTS behind)


#26

The same ALSA error with 1.7.0.1.


#27

Thanks for testing. Being a bit clueless right now… why does it work for some and for others not…