Building gnome-3-34-extension failure

For some reason while building the latest version of my snap the build failed several times with “IP connection” issues, so I rebooted.
Following reboot, I attempted to build my snap and the snapcraft system decided to completely refresh itself with a new snapd etc.
Once the refresh process had finished I tried to make my snap and it failed with this error:

Building gnome-3-34-extension 
make -j2
gcc -Wall -O2 -o -fPIC -shared ./../src/bindtextdomain.c -ldl
./../src/bindtextdomain.c:5:10: fatal error: errno.h: No such file or directory 
#include <errno.h>
compilation terminated.
Makefile:20: recipe for target 'desktop-launch' failed
make: *** [desktop-launch] Error 1
Failed to run 'make -j2' for 'gnome-3-34-extension': Exited with code 2.
Verify that the part is using the correct parameters and try again.

I have also tried the make the snap with gnome-3-28-extension with success:

Pulling photonotebook 
Building gnome-3-28-extension 
make -j2
gcc -Wall -O2 -o -fPIC -shared ./../src/bindtextdomain.c -ldl
make install DESTDIR=/root/parts/gnome-3-28-extension/install
install -d /root/parts/gnome-3-28-extension/install/gnome-platform
install -d /root/parts/gnome-3-28-extension/install/data-dir
install -d /root/parts/gnome-3-28-extension/install/data-dir/icons
install -d /root/parts/gnome-3-28-extension/install/data-dir/sounds
install -d /root/parts/gnome-3-28-extension/install/data-dir/themes
install -D -m755 desktop-launch "/root/parts/gnome-3-28-extension/install/snap/command-chain"/desktop-launch
install -D -m644 "/root/parts/gnome-3-28-extension/install/lib"/

.... and so on to complete the snap build

Please can anyone suggest a solution?

many thanks

Can you share your yaml?

Try snapcraft clean first and retry?

I have tried snapcraft clean and it made no difference.
I have also tried using gnome-3-28-extension with success (please see the edit to my last post)


name: photonotebook
title: PhotoNoteBook
version: '1.2'
summary: A digital photography library manager and notebook 
license: Proprietary
description: PhotoNoteBook is a digital photograph library manager enabling collections of images and the making of notes and memo's for the collections and the photographs. 
icon: photonotebook.png 

confinement: strict
grade: stable
base: core18
    command: bin/photonotebook
      - gnome-3-34
    plugs: [home, unity7,  opengl, network, removable-media, optical-drive]

    plugin: dump
    source: ./photonotebook/
    stage-packages: [libfreetype6, libpng16-16, libx11-6, libxext6, libxi6, libxrender1, libxtst6, libasound2, libcanberra-gtk-module, libcanberra-gtk3-module ]

and I’ve just tried it again with gnome-3-34-extension and it has completed!!
something is a little … um!


This is indeed strange! We have tests for this under CI, so at least we know that if you have a clean environment this all works. Out of interest, did you switch channels for snapcraft while encountering these issues or can think of anything that changed between the time it worked and the time it failed? Are you using default Snapcraft, “–use-lxd” or “–destructive-mode”?

Hi Sergiusens,

I am using default snapcraft and I haven’t been channel switching!

Having thought about it for a while, I remember now that when I first started pulling in gnome-3-28 some time ago I had exactly the same problem, that I solved (so I thought) by installing linux-libc-dev package into my base system.

I subsequently started using gnome-3-34 and it was ok for a while until the snapcraft system refresh yesterday then I had the problem.

However, this time it seems to have cleared itself up without my intervention.