"Build with Github" => can't trigger new build

I am using “Build with github” for 6 packages:

My problem: I wasn’t able to trigger any new build since a week. I don’t know why. Do you have any ideas?

My hypothesis: maybe I triggered too many build a week ago. I updated my own multimedia library:

and all the snap configurations of all games depending on it. I did it 3-4 times because of errors. I probably triggered too many build (~16). Maybe my account is now legitimately frozen for a few days?

Do you have any guesses why I can’t build anymore?

A new build is triggered only on “Dependency changes”, but never on “Commit” or “Manual build”

I still can get anything built. I even tried to remove and add back my repository. Even the initial build doesn’t start.

I solved my issue myself. For future readers:
It turns out the website do not output any errors when it can’t parse the snapcraft.yaml. The .yaml file can be fine locally, but not on the website.

What I did:

  • Convert the .yaml to .json and back.

Same here, Triggered new build button didn’t worked.

Found out that my snapcraft.yaml can’t run because it had invalid syntax (comment in override-build: that started from the beginning of the lines).

Turns out that Triggered new build button does not show any response if processing the snapcraft.yaml failed.

After fixing the snapcraft.yaml file and pushing it to github I had to go back to My snaps page and back to my snap Builds page in order for the Triggered new build button to work again.