Build started failing in docker

See the logs here:

E:The method driver /snap/snapcraft/current/usr/lib/apt/methods/https could not be found.
W:Is the package apt-transport-https installed?

I’m using the snapcore/snapcraft:stable image with the apt-transport-https package installed.

This issue is new with no change to our build.

I’ve tried other channels and we are getting the same error.

I tried another method, and it failed similarly.


@Wimpress FYI, this will block the release of our package.

Hi Travis,

This message is to tag @sergiusens so he gets pinged about this, too.


I have found the issue. I had added a package source that was https. If I remove it, before I build the snap it works. I’ve updated my PR and making sure it works on a clean system.

Here is the change:

Here is the full file:

This is a known issue: Bug #1790819 “snapcraft 2.43 snap can’t access to HTTPS APT sour…” : Bugs : Snapcraft

1 Like

Sorry about this, this is already fixed on edge if you do not mind confirming it works there (snapcore/snapcraft:edge).

1 Like

Sorry, I’ve already fixed my build environment to remove the HTTPS source after I get the package I need from it. I don’t see a need to add it back since I’m building in a container. I tried edged yesterday and it did NOT work.

Snapcraft 2.43.1 resolves the issue of accessing apt repositories over https.

  • Snapcraft 2.43.1 is available via the Snap Store in the stable channel.
  • Snapcraft 2.43.1 is available via apt updates for 16.04 and 18.04

@sergiusens Can you confirm which version of the Snapcraft Docker images include 2.43.1.

Sorry to say, but 2.43.1 is not the one you need to get this resolved, it is 2.44, specifically LP: #1790819.

2.44 might be tagged and bagged tomorrow, allowing us a new call for testing which would allows snapcore/snapcraft:candidate to have the fix.