[bug-website] Endless Redirect on Snap Store Website - Login SSO

I tried to login to the Snap Store on the Website snapcraftdio . (alias d = . due to new user restrictions for links …) I already had an account on login d ubuntu d com, so it shouldve not been an issue to login via sso.

Trying to login with the existing login, results in an endless redirect between login d ubuntu d com and snapcraftdio.

I am not sure why. I cleared Cookies, used a different system, a different browser, and another device, none worked. But after experimenting a bit, when I went to dashboard.snapcraft.io the login worked here, but the website said that i need to accept TOS for the Store. This was not the case for snapcraft d io, only the dashboard website showed me this TOS accept option. I think thats what failed the Login on the main page, with the endless redirect. I did not accept TOS yet. After accepting TOS on the dashboard page, the login on the main page also worked flawless.

There might be an issue that needs to be solved eventually.

Have a nice one,


1 Like

I have some issue with my corporate account, do you found a solution ? note: on the another canonical sites, all is works fine. For example, i successful logined on the ubuntu.com but not https://snapcraft.io/ User login : quasarappdevelop@gmail.com

Yes, i did find a solution.

Basically, after I visited https://dashboard.snapcraft.io I got greeted by an “you need to accept TOS” checkbox. After confirming, I was not redirected anymore and the login worked.

1 Like