Bug report: Thunderbird latest/beta 78.3.1

I looked for the right way to report snap bugs and found this thread which suggested just filing them on the forums and tagging the snapper. So I hope you see this, @kenvandine :slight_smile:

Issue: Thunderbird crashes upon launch
Steps to reproduce:

  • Install Thunderbird latest/beta 78.3.1
  • Run snap run thunderbird from the command line
    Expected results: Thunderbird starts up with account setup wizard
    Actual results: Mozilla Crash Reporter pops up with all text replaced by rectangles (see linked screenshot)
    OS: Ubuntu 20.04
    Desktop: GNOME on Xorg

Terminal output (apologies for the garbled powerline stuff):
mads  ~  snap run thunderbird
Gtk-Message: 13:54:23.157: Failed to load module “canberra-gtk-module”
Gtk-Message: 13:54:23.158: Failed to load module “canberra-gtk-module”
ExceptionHandler::GenerateDump cloned child 749349
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal…
mads  ~  Gtk-Message: 13:54:24.528: Failed to load module “canberra-gtk-module”
Gtk-Message: 13:54:24.529: Failed to load module “canberra-gtk-module”

https://cloud.madsmi.de/s/wkZ2YbJntNM7pkL

@seb128 can you reproduce this? It’s starting fine for me, but I don’t really use it.

I’m running it here on 20.10. But mine was already setup. So it’s possible I’m not on the same code path as I won’t be running the first run wizard.

I am unable to reproduce issue rather than the “daily build” welcome screen :wink:

I tried uninstalling, rebooting and reinstalling. Same result. Are there any snap options that I can reset? Other variables that are relevant to snap that I can tweak? I am getting the same thing from the stable release BTW, and the downloaded tar.bz2 off of mozilla.net runs fine.

Try dropping all the fontconfig caches.

1 Like

I removed the symlink ~/.local/share/fonts (linked to a static folder with various fonts) and ran fc-cache --really-force . Then ran snap run thunderbird. That seems to have done it - now I’m getting the account setup wizard. I wonder if it’s the symlinking or one specific font that kills it?

Thanks for the help, guys.

EDIT: I guess I spoke a little too soon. Thnderbird runs and responds but all windows I open have rectangles of varying widths as titles on the title bars (similar to the ones in the screenshot above). I don’t think I have installed any fonts systemwide and all those I had as a user should have been removed by the actions above.