[BUG] Channel selection in snap-store different to snapcraft

I had to install PhpStorm via CLI, because I always want to be in the latest/edge channel. I can do that just fine via snapcraft.io and then CLI sudo snap install phpstorm --edge --classic

But when using the snap-store I can only select 2020.2/edge which means I won’t get the next EAP.

That’s what it looks like in the snap store application:
Screenshot_20200615_134233

And that’s what it looks like on snapcraft.io:

Btw, is this the best place to report bugs?

Bugs for the desktop client should be filed at https://bugs.launchpad.net/snap-store, thanks!