Breeze Cursor Not Being detected

I have been facing this issue ever since Plasma 6 got released, am using Arch Linux.

❯ snap --version
snap     2.61.3-1
snapd    2.61.3-1
series   16
cachyos  -
kernel   6.8.1-4-cachyos-lto

I tried, Firefox, spotify Cursor I am using is Breeze Light from plasma 6

Hi ! @Syntist .

Can you give more information about the issue ?

Yes, the issue is snap apps are not following new Plasma 6.0 Cursor. All app i tried fall back to old cursor, even though i have installed gnome -theme package on snap.

Discord, firefox, brave, vscode. They are not respecting the cursor theme

If you zoom into the images i shared and check the cursor on dolphin and cursor on snap apps

Perhaps, theses snaps are not compatible with Plasma 6.0 .

According to my understanding the gtk-common-theme doesn’t contain breeze-light cursor theme maybe that can be an issue.

Yes @Syntist , I seriously think so.

@baldeuniversel is it possible to mount icons themes from host system. So the themes are detected?

Yep ! You can share your custom icons like this (after downloading them):

sudo mv your-custom-icons-folder /usr/share/icons

After downloading and share your custom icons, you can use some tools to perform what you want (like gnome-tweaks

Okay, so basically snap uses system themes? But still it can’t detect the breeze cursor theme?

@Syntist !

By default, I don’t think (according to the latest news :slightly_smiling_face:).

The snap (like spotify) in question must have to perform some config like this :

name: your-snap-name
version: '1.0'
summary: Your Snap Summary
description: |
  Your Snap Description

    interface: content
    target: $SNAP/share/themes
    default-provider: gtk-common-themes
    interface: content
    target: $SNAP/share/icons
    default-provider: gtk-common-themes
    interface: content
    target: $SNAP/share/sounds
    default-provider: gtk-common-themes

    command: desktop-launch $SNAP/bin/your-app
    plugs: [gtk-3-themes, icon-themes, sound-themes]