Blank window Google authorization

Hello everyone.

Approximately one month ago I wrote about that after snapping my JavaFX project it has the blank window of Google authorization, but issue was not solve. Interest, but in IDE all is ok. Problems begin when snap file was snapped. Unfortunately, I cannot show you source code of the application, but I can show you my .yaml file.

name: deletebg
base: core18
version: '2.10.e'
summary: Delete Background is an easy service for quickly editing your images.
icon: snap/gui/icon.png
license: 'MIT'
description: ...
grade: stable
confinement: strict

    plugin: maven
    source: .
    source-type: local
      - openjdk-11-jre
      - openjfx
      - libopenjfx-jni

      - gnome-3-28
    command: bin/java -jar $SNAP/jar/deletebg-2.10.e.jar
      - desktop-legacy
      - desktop
      - home
      - network
      - browser-support

I tried to add to my code the “System.setProperty("", "true");” but it wasn’t help.

One more, I tried to find the login text field and input the login. But after that I caught an error:

at java.base/java.nio.Buffer.nextGetIndex(
at java.base/java.nio.DirectByteBuffer.getInt(
at com.sun.webkit.WebPage.paint2GC(
at com.sun.webkit.WebPage.paint(
at java.base/java.util.concurrent.Executors$
at java.base/java.util.concurrent.FutureTask.runAndReset(
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/

You can test it installing application It names “deletebg

you should start with installing the snappy-debug snap and run the snappy-debug command in one terminal while starting your app from another terminal, that should show you any errors the app produces as well as any errors caused by the snap environment…

So, I did it. Result

you should definitely add the network-bind plug, the other cgroup related bits that try to set the memory limit seem not fatal to me …

do you see any errors from the app itself in the terminal window you started it in ?

I added the network-bind plug. It’s not solved the issue.

I get the next warnings from app itself:

(java:15455): Gtk-WARNING **: 16:30:41.216: Theme parsing error: gtk.css:1566:23: ‘font-feature-settings’ is not a valid property name

(java:15455): Gtk-WARNING **: 16:30:41.219: Theme parsing error: gtk.css:3618:25: ‘font-feature-settings’ is not a valid property name

(java:15455): Gtk-WARNING **: 16:30:41.220: Theme parsing error: gtk.css:4080:23: ‘font-feature-settings’ is not a valid property name

Do you see these errors outside of the snap as well? What gnome version are you using outside the snap?

When the application is running in the IDE I don’t see these errors.

roman@roman-HP-Pavilion-Notebook:~$ gnome-shell --version
GNOME Shell 3.36.9

@kenvandine any ideas for this?

Any ideas hot to solve this issue? Or it’s impossible solve?