Auto-import assertion not working in channel stable/beta

Hey Guys,

I try to create my own image with an specified system-user via the USB-Key way I had tried stable and beta channel with no luck on booting is says that the service “auto-import assertions” has failed to start. I should look into the logfiles whats going wrong. But I can’t the user is didn’t created so far and I can’t login, is that a bug?
Core version: 2.29.3 revision 3443 same version is in stable channel.

When I use the edge version of core all working fine but the core is not running well and have some problems to get working like mounting and unmounting the core snap in a random way.

I have read some similiar topics from here but looks problem is not really solved.

I create system-user with only ssh keys to login without password with the from github.


What device is that on (i see 3443 is armhf) …
What are the modifications you do (own kernel, own gadget ?)
Is the USB key vfat formatted ?

They USB key is vfat like 2GB of size.
The device is an raspberry Pi3.
Only use the own model structure to sign and create the image no extra gadgets or kernel.

Mhm thats weird , its looks that sometimes the core snap is not working from beta channel,
but currently it works, I have change nothing maybe like some reboots of the device self.

I will try to reproduce this and will take some screenshots


@ogra I guess I have figured out what happens, when I start the Pi at first time without extra snaps like network-manager and modem-manager the auto-import from the file will maybe get broken during the “short” init from the service like 5-6 seconds after.

When I did not use extra snaps in the image and install it during my script from the firstboot the auto-import is working as excpeted.

How long should the script wait of the auto-import before the first of second reboot is appear?
One minute, two minutes?


i think the auto-import bits are a thing @pedronis implemented, this sounds like there is some race going on due to the installing/validating of the additional extra-snaps

@mvo implemented it actually

@ogra @pedronis the funny thing in the edge channel for the core it works all as excpeted also with the extra snaps but is not currently useable

now I have my workaround for now, but maybe its already fix in newer releases then when a edge core comes to beta or stable.


well, the next release should be soon, please keep us posted if it then works for you in the other channels …

Hey @ogra I have yesterday tested with the new beta core snap and it’s unfortentaily not working

Core version: 3522, channel beta
Additional Snaps in the ubuntu-image by creation
modem-manager, network-manager

When I did a “post” install from Modem-manager and network-manager during my service process on boot the user create assertion works fine from USB stick.