Auto-connection request: pi-bluetooth (again!)

The pi-bluetooth snap is currently failing on UC22 (LP: #1970432) because the serial-port plug is not auto-connecting to the bt-serial slot on the pi gadget.

How this ever worked in UC18 and UC20 is a bit of a mystery, but we’d be most grateful if this could be rectified by adding this as an auto-connection.

For reference:

I am surprised if this worked in the past as there is no existing auto-connect declaration for serial-port for pi-bluetooth. +1 from me for this as it is required functionality for the snap.

1 Like

+1 from me as well!

  • Daniel

Actually - I went looking at these snaps’ configuration and it’s odd it stopped working, because the pi gadget snap has the proper configuration AAUI in its serial-port slot:

  "allow-auto-connection": {
    "plug-snap-id": [

@joc if you could provide some logs about what happens when you try to install it I’d be grateful. It might have to do with greediness, as I notice the pi gadget snap has a ton of serial-port interfaces.

  • Daniel

Indeed - if the gadget snap already configures auto-connection then it would not be needed for the pi-bluetooth snap itself - so I agree this is likely due to plug greediness (or lackthereof).

We got this working by configuring on the pi snap’s side. The missing component was some scoping by slot-names.

This request can be considered complete :slight_smile:

  • Daniel