Arch Linux no longer runs snaps?


#1

i currently have to use a snap to use my vpn, riseup-vpn. however, in what seems to be a larger problem(?) snaps no longer seem to be files i can run, at all.
doing “sudo snap run riseup-vpn” returns
“error: cannot find app “riseup-vpn” in “riseup-vpn””
system details:
OS: Arch Linux
Kernel: x86_64 Linux 5.0.13-arch1-1-ARCH
Packages: 789
DE: KDE 5.57.0 / Plasma 5.15.5


#2

You have to use the name of the command provided by the snap. NOT the name of the snap. E.g.

snap run riseup-vpn.launcher


#3

ok, this is starting to look more like a problem with this specific snap, but ill put this here just in case
after using the methods to kill the program described here under “Force Quit” i ran the command you gave me
it returned… this
sudo snap run riseup-vpn.launcher
2019/05/11 13:31:43 Error detecting the system locale: unable to locale locale
2019/05/11 13:31:43 firewall stop

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:43.426: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:43.449: Unable to get the session bus: Error spawning command line ?dbus-launch --autolaunch=624abfc8e52343eeb67ca11ef9290ac2 --binary-syntax --close-stderr?: Child process exited with code 1

(bitmask-vpn:2600): LIBDBUSMENU-GLIB-WARNING **: 13:31:43.449: Unable to get session bus: Error spawning command line ?dbus-launch --autolaunch=624abfc8e52343eeb67ca11ef9290ac2 --binary-syntax --close-stderr?: Child process exited with code 1

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:43.449: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:43.449: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources
2019/05/11 13:31:43 openvpn stop

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:43.539: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:43.539: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources
Fontconfig warning: “/etc/fonts/fonts.conf”, line 5: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/fonts.conf”, line 6: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/fonts.conf”, line 6: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/fonts.conf”, line 6: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/fonts.conf”, line 7: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/fonts.conf”, line 7: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/fonts.conf”, line 9: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/10-hinting-slight.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/20-unhint-small-vera.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/30-metric-aliases.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/40-nonlatin.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/40-nonlatin.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/40-nonlatin.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/40-nonlatin.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/40-nonlatin.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/40-nonlatin.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/40-nonlatin.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/45-generic.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/45-generic.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/45-generic.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/45-generic.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/45-generic.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/45-generic.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/45-generic.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/45-latin.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/45-latin.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/45-latin.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/45-latin.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/45-latin.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/45-latin.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/45-latin.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/49-sansserif.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/49-sansserif.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/49-sansserif.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/49-sansserif.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/49-sansserif.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/49-sansserif.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/49-sansserif.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/50-user.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/50-user.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/50-user.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/50-user.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/51-local.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/51-local.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/51-local.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/51-local.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/51-local.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/51-local.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/51-local.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/60-generic.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/60-generic.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/60-generic.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/60-generic.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/60-generic.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/60-generic.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/60-generic.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/60-latin.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/60-latin.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/60-latin.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/60-latin.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/60-latin.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/60-latin.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/60-latin.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/65-fonts-persian.conf”, line 34: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/65-fonts-persian.conf”, line 35: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/65-fonts-persian.conf”, line 35: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/65-fonts-persian.conf”, line 35: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/65-fonts-persian.conf”, line 36: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/65-fonts-persian.conf”, line 36: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/65-nonlatin.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/65-nonlatin.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/65-nonlatin.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/65-nonlatin.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/65-nonlatin.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/65-nonlatin.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/65-nonlatin.conf”, line 8: unknown element “description”
Fontconfig warning: “/etc/fonts/conf.d/69-unifont.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/69-unifont.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/69-unifont.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/69-unifont.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/69-unifont.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/69-unifont.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/80-delicious.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/80-delicious.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/80-delicious.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/80-delicious.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/80-delicious.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/80-delicious.conf”, line 6: invalid attribute ‘version’
Fontconfig warning: “/etc/fonts/conf.d/90-synthetic.conf”, line 4: unknown element “its:rules”
Fontconfig warning: “/etc/fonts/conf.d/90-synthetic.conf”, line 5: unknown element “its:translateRule”
Fontconfig error: “/etc/fonts/conf.d/90-synthetic.conf”, line 5: invalid attribute ‘translate’
Fontconfig error: “/etc/fonts/conf.d/90-synthetic.conf”, line 5: invalid attribute ‘selector’
Fontconfig error: “/etc/fonts/conf.d/90-synthetic.conf”, line 6: invalid attribute ‘xmlns:its’
Fontconfig error: “/etc/fonts/conf.d/90-synthetic.conf”, line 6: invalid attribute ‘version’
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:44.168: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:44.168: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): Gdk-CRITICAL **: 13:31:44.172: gdk_window_thaw_toplevel_updates: assertion ‘window->update_and_descendants_freeze_count > 0’ failed

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:48.668: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:48.668: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:48.669: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:48.669: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:48.669: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:48.669: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:53.712: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:53.712: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:53.712: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:53.712: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:53.712: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:53.712: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:58.763: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:58.763: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:58.763: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:58.763: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:31:58.763: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:31:58.763: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:03.812: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:03.812: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:03.812: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:03.812: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:03.812: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:03.812: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:08.858: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:08.858: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:08.858: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:08.858: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:08.858: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:08.858: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:13.913: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:13.913: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:13.913: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:13.913: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:13.913: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:13.913: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:18.983: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:18.983: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:18.983: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:18.984: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:18.984: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:18.984: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:24.037: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:24.037: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:24.037: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:24.037: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:24.037: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:24.037: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:29.084: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:29.084: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:29.084: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:29.084: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:29.084: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:29.084: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:34.128: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:34.128: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:34.128: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:34.129: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:34.129: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:34.129: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
/snap/bin/riseup-vpn.launcher
(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:39.176: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:39.176: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:39.176: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:39.176: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:39.176: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:39.176: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:44.221: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:44.221: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:44.221: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:44.221: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): libappindicator-WARNING **: 13:32:44.221: Using ‘/tmp’ paths in SNAP environment will lead to unreadable resources

(bitmask-vpn:2600): GdkPixbuf-WARNING **: 13:32:44.221: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
^Z
[1]+ Stopped sudo snap run riseup-vpn.launcher

i think i can see a few of the problems here, but… whew


#4

Check out:
https://0xacab.org/leap/bitmask-vpn/issues/77

You have to create a symlink:

mkdir -p /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/
ln -s /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache


#5

thank you so much! i will have to wait and see if the problem stays solved, ie, if the vpn doesnt close after an hour or so, but i thank u for ur help!!!