App crashes and low resolutions icons

I have been snapping atom(Just to learn snapcraft really!) from the github branch, on my local machine using the nodejs plugin over the last few days, and have managed to get it to run on my machine at least.


However, I see that atom keeps randomly crashing on

  • file save
  • package update
  • theme update

and other miscellaneous actions.

I do not know how to troubleshoot.

I see all my env variables set properly.

I tried the snap in devmode as well, with snappy-debug. After which, I plugged in

  • opengl
  • pulseaudio ? (snappy-debug suggested)
  • gesttings

If I launch from CLI, I get these messages on the prompt

    ln: failed to create symbolic link '/home/sherlock/snap/snapped-atom/4/.config/gtk-2.0/gtkfilechooser.ini': File exists
    Gtk-Message: Failed to load module "canberra-gtk-module"
    bash: cannot set terminal process group (-1): Inappropriate ioctl for device
    bash: no job control in this shell

I do not know what they mean.

I confined it to strict only after running in devmode, where all APPARMOR messages were
saying ALLOWED

Here is a paste of snappy-debug after running atom for about half an hour trying various stuff

Snappy-Debug Log

Here are the env variables as in devmode


the graphics is poor for the icons. Not smooth.

Screenshot from 2017-09-07 01-16-05

Snapcraft.yaml for reference

You could cheat and see how Martin did it :stuck_out_tongue: See if that gives you any clues…

1 Like

Also, the graphics is poor for the icons. Not smooth.

Try pointing to a 256x256 pixel PNG or even better an SVG if Atom has them anywhere. It looks like you’re currently using a 16x16 which is then being scaled-up.

1 Like

Well it is actually, a 1024x1024 png scaled down I guess. No SVG.


I copied this bit over from snapcrafters version of atom.

sed -i 's|Icon=atom|Icon=/usr/share/pixmaps/atom\.png|g' usr/share/applications/atom.desktop

Isn’t this supposed to replace Icon=atom to Icon=/usr/share/pixmaps/atom.png ?

Apparently it isn’t

[Desktop Entry]
Comment=A hackable text editor for the 21st Century.
GenericName=Text Editor
Exec=/usr/share/atom/atom %F

Edit : It is . I was just seeing the wrong locations

I dont understand! I have now tried different possible sizes for the icon,

  • 256x256
  • 480x480
  • 960x960

On Ubuntu 16.04, the graphics just doesnt want to like a size for the icon. It looks Horrid.

Even the dialog boxes for file --> open

they look like the ones on windows 98. literally!