Almost all snaps broke overnight and need to be reinstalled

This morning I wanted to connect to my work machine using remmina, and it wouldn’t start. So I went into a terminal:

:~$ remmina -v
/snap/remmina/4587/usr/bin/remmina: error while loading shared libraries: cannot open shared object file: No such file or directory
:~$ sudo snap refresh remmina
snap “remmina” has no updates available
:~$ sudo snap remove remmina
remmina removed
:~$ sudo snap install remmina
remmina v1.4.10+git5.717708b1 from Remmina Upstream Developers (remmina✓) installed
:~$ remmina

Remmina now works but all profiles are gone :-/

So I tried to open GIMP:

:~$ gimp
/snap/gimp/322/usr/bin/gimp: error while loading shared libraries: cannot open shared object file: No such file or directory
:~$ snap list gimp
Name Version Rev Tracking Publisher Notes
gimp 2.10.22 322 latest/stable snapcrafters -
:~$ sudo snap refresh gimp
snap “gimp” has no updates available

Let’s try Libreoffice:

:~$ libreoffice
/snap/libreoffice/196/lib/libreoffice/program/soffice.bin: error while loading shared libraries: cannot open shared object file: No such file or directory
:~$ snap info libreoffice
name: libreoffice
summary: LibreOffice is a powerful office suite including word processing and creation of
spreadsheets, slideshows and databases
publisher: Canonical✓
license: unset
description: |
LibreOffice is a powerful and free office suite, used by millions of people around the world. Its
clean interface and feature-rich tools help you unleash your creativity and enhance your
productivity. LibreOffice includes several applications that make it the most versatile Free and
Open Source office suite on the market: Writer (word processing), Calc (spreadsheets), Impress
(presentations), Draw (vector graphics and flowcharts), Base (databases), and Math (formula

  • libreoffice.base
  • libreoffice.calc
  • libreoffice.draw
  • libreoffice.filebug
  • libreoffice.impress
  • libreoffice
  • libreoffice.math
  • libreoffice.writer
    snap-id: CpUkI0qPIIBVRsjy49adNq4D6Ra72y4v
    tracking: latest/stable
    refresh-date: 2020-11-01
    latest/stable: 2020-10-31 (196) 631MB -
    latest/candidate: 2020-12-17 (200) 631MB -
    latest/beta: ↑
    latest/edge: 2020-10-08 (193) 655MB -
    installed: (196) 631MB -
    :~$ sudo snap refresh libreoffice
    snap “libreoffice” has no updates available

:~$ inkscape
ln: failed to create symbolic link ‘/home/sam/snap/inkscape/8049/.config/gtk-2.0/gtkfilechooser.ini’: File exists
xkbcommon: ERROR: failed to add default include path /usr/share/X11/xkb
/home/sam/snap/inkscape/common/.cache/gio-modules/ cannot open shared object file: No such file or directory
Failed to load module: /home/sam/snap/inkscape/common/.cache/gio-modules/
/home/sam/snap/inkscape/common/.cache/gio-modules/ cannot open shared object file: No such file or directory
Failed to load module: /home/sam/snap/inkscape/common/.cache/gio-modules/
/home/sam/snap/inkscape/common/.cache/gio-modules/ cannot open shared object file: No such file or directory
Failed to load module: /home/sam/snap/inkscape/common/.cache/gio-modules/
/home/sam/snap/inkscape/common/.cache/gio-modules/ cannot open shared object file: No such file or directory
Failed to load module: /home/sam/snap/inkscape/common/.cache/gio-modules/
GLib-GIO-Message: 09:58:02.897: Using the ‘memory’ GSettings backend. Your settings will not be saved or shared with other applications.
xkbcommon: ERROR: failed to add default include path /usr/share/X11/xkb
Segmentation fault
:~$ sudo snap info inkscape
name: inkscape
summary: Vector Graphics Editor
publisher: Inkscape Project (inkscape✓)
license: GPL-3.0
description: |
Inkscape is a Free and open source vector graphics editor. It offers a rich set
of features and is widely used for both artistic and technical illustrations
such as cartoons, clip art, logos, typography, diagramming and flowcharting.
It uses vector graphics to allow for sharp printouts and renderings at
unlimited resolution and is not bound to a fixed number of pixels like raster
graphics. Inkscape uses the standardized SVG file format as its main format,
which is supported by many other applications including web browsers.

SVG Features include basic shapes, paths, text, markers, clones,
alpha blending, transforms, gradients, and grouping.
In addition, Inkscape supports Creative Commons meta-data, node-editing,
layers, complex path operations, text-on-path, and SVG XML editing.
It also imports several formats like EPS, Postscript,
JPEG, PNG, BMP, and TIFF and exports PNG as well as multiple vector-based

Inkscape’s main motivations are to provide the Open Source community
with a fully W3C compliant XML, SVG, and CSS2 drawing tool emphasizing a
lightweight core with powerful features added as extensions, and the
establishment of a friendly, open, community-oriented development

  • inkscape
  • inkscape.viewer
    snap-id: tIrcA87dMWthuDORCCRU0VpidK5SBVOc
    tracking: latest/stable
    refresh-date: 2020-10-23
    latest/stable: 1.0.1-0767f8302a-2020-10-17 2020-10-22 (8049) 145MB -
    latest/candidate: 1.0.1-770341a87f-2020-12-31 2021-01-04 (8373) 146MB -
    latest/beta: ↑
    latest/edge: 1.1-dev-64a343e585-2021-01-05 2021-01-06 (8383) 359MB -
    installed: 1.0.1-0767f8302a-2020-10-17 (8049) 145MB -
    :~$ sudo snap refresh inkscape
    snap “inkscape” has no updates available
    :~$ ll /home/sam/snap/inkscape/common/.cache/gio-modules/
    lrwxrwxrwx 1 sam sam 76 Jun 28 2019 /home/sam/snap/inkscape/common/.cache/gio-modules/ -> /snap/inkscape/4693/usr/lib/x86_64-linux-gnu/gio/modules/

I do not have version 4693 installed anymore…

:~$ sudo snap remove inkscape
inkscape removed
:~$ sudo snap install inkscape
inkscape 1.0.1-0767f8302a-2020-10-17 from Inkscape Project (inkscape✓) installed
:~$ inkscape

#inkscape works

I did a few random tests but I honestly don’t fell much for reinstalling (all?) snaps and lose historical data such as the remmina profiles in the process. The Brave snap still works. Regular applications work as well. AppImages do too. I have an up to date Groovy Gorilla install.

this looks like either an issue with the gnome extension all these snaps use or something with snapd itself … check your snap changes for errors


snap changes returns nothing for:


-> except the re-installation I did this morning

I see no option to see more history, it seems very limited tbf.

was anything for snapd itself in the list ?

yeah, it sadly is a ringbuffer that gets wiped on a time based schedule …

snapd is not a snap on my system at least ?

I have:
snapd/groovy-updates,now 2.48+20.10 amd64 [installed]

It got installed during the focal->groovy update on december 12:

$-:\ grep snapd apt-term.log
Preparing to unpack …/096-gir1.2-snapd-1_1.58-0ubuntu0.20.10.0_amd64.deb …
Unpacking gir1.2-snapd-1:amd64 (1.58-0ubuntu0.20.10.0) over (1.58-0ubuntu0.20.04.0) …
Preparing to unpack …/097-libsnapd-glib1_1.58-0ubuntu0.20.10.0_amd64.deb …
Unpacking libsnapd-glib1:amd64 (1.58-0ubuntu0.20.10.0) over (1.58-0ubuntu0.20.04.0) …
Preparing to unpack …/734-snapd_2.48+20.10_amd64.deb …
Unpacking snapd (2.48+20.10) over (2.48+20.04) …
Setting up snapd (2.48+20.10) …
snapd.failure.service is a disabled or a static unit, not starting it.
snapd.snap-repair.service is a disabled or a static unit, not starting it.
Setting up libsnapd-glib1:amd64 (1.58-0ubuntu0.20.10.0) …
Setting up gir1.2-snapd-1:amd64 (1.58-0ubuntu0.20.10.0) …

I can’t wrap my head around this.

the deb of snapd is completely irrelevant on ubuntu systems (it is only used for re-executing into the snapd snap), please check snap changes for anything mentioning the snapd snap …

snapd is not installed as a snap on my desktop. I checked my laptop and on that is indeed installed. On the desktop it is not. Both are Groovy Gorilla systems, upgraded from Focal last December.

As I run off zfs I could go back until 2020-01-31 in the snapshots, as far as I can trace back the snapd snap was never installed on this system.

So now I have the option to ignore this (it should not disappear, even when it is supposed to be there I think I never had it on this system), reinstall the snapd deb to see if it pulls the snap it in, or install the snapd snap directly?

i’d just install the snapd snap … though it is weird that you do not have it, normally do-release-upgrade or the graphical update manager (which is just a UI for the former after all) should manage such transitions …

Installed, but no change. I guess I will be reinstalling all snaps that refuse to start.

Confirmed workaround: reinstall impacted snaps as needed. Bummer.