Allow the program to print

How to properly allow the program to print?

$ grep plugs snapcraft.yaml
plugs: [network, x11, home, unity7, gsettings, opengl, optical-drive,

Just now I see

Jun 20 14:38:13 vasilisc kernel: [13788.508201] audit: type=1400
audit(1497958693.631:339): apparmor=“DENIED” operation=“connect”
profile=“” name="/run/cups/cups.sock" pid=13388 comm=“App”
requested_mask=“wr” denied_mask=“wr” fsuid=1000 ouid=0

I think that the problem could be that, besides declaring it, you need to connect the cups-control interface manually once the snap is installed, with something like:

sudo snap connect snap-name:cups-control

I will enter this command, but how do other users know that it needs to be
entered? The program can be started without a terminal.

We’re working on allowing users to connect interfaces via the GUI (e.g. GNOME Software).

This is a really useful test case for us, so tagging @robert.ancell for his info.

1 Like

I’ve added a printing toggle to the wip/rancell/permissions branch on GNOME Git. Will discuss this next week at the Snappy sprint as part of the general discussion on how we implement this feature.

I’m just curious as to the current status of this? I only ask as I cannot print in brave and I am just trying to determine if:

a) not yet supported
b) snap needs additional options to work
c) my system is the cause.

Thank you.