Adobe reader (mmtrt) not seeing my printer (cups)

Hi, trying to get Adobe Reader snap to print out a PDF to my printer, no printer showing to adobe.

Installed through software centre and checked the “Permissions” button but no printer option ?

Used the command “snap connections acrordrdc” in terminal, no printers or cups listed ?

Think this might be a wine issue, cant see any setting for printers on winecfg ?

Help… (ubuntu 18.04 - Gnome 3 - X11)

OK done a little be more searching on this, its about connecting the “cups-control” [interface] to the snap “acrordrdc” using the snap command line tools…so

snap connect acrordrdc:cups-control :cups-control

returns “no plug” error ?

Tried both versions from the snap store stable & edge also tried adding --classic to snap install command line, not having any of it.

snap info --verbose acrordrdc

returns “Confinement: Strict” and "Devmode:false"

Q: How do I force / override the snap connect function ?


It looks like the acrordrdc snap does not plug the cups-control interface, so the snap author would need to add this plug to their snapcraft.yaml for you to connect that interface.

Unfortunately the snap author did not add contact information to the snap description, however the LP author seems to match this repo on GitHub, so you could try filing an issue on that GitHub repository asking for help adding this to the snap (and also maybe for them to set a contact setting for the snap, even just to the GitHub issues page is enough I think).

Also, to clarify, the --classic flag only allows installing a snap that has been published with classic confinement, it does not change the confinement of a snap. The acrordrdc snap is not published under classic confinement, so this flag does nothing:

$ snap install acrordrdc --classic
Warning: flag --classic ignored for strictly confined snap acrordrdc

acrordrdc 2018.011.20063 from Taqi Raza (mmtrt) installed

If you saw somewhere online in a tutorial or something that this flag changes the confinement, could you let us know so we can try to get that information corrected? Unfortunately this is a common misconception we see with some frequency.

Hope this helps!

Thanks you for getting back to me with the confirmation.

No I hadn’t read anywhere that you could hack a snap by adding --classic I just tried it. The thinking being that --classic means all general plugin slots would be available.

He actually puts in his description “Read & Print PDF’s” but obviously never checked that the snap actually printed…

Surprised I’m the first to notice this…

I only tried Adobe as I have a PDF form thats printing bordered boxes strangely in all the other Linux pdf viewers and in Adobe are showing as circles… go figure

I am amazed how well this wine based snap is working. But I did have to install wine 4.0 first as not installed on Ubuntu 18.04