Why does my GitHub-to-snap build fail?

My snapcraft build fails, showing the following error massage: deb-systemd-invoke only supports /usr/sbin/policy-rc.d return code 101 and 104!. You can find the complete log here. Does anyone know how to fix this?

Since I considered it a bug, I filed a report.

That is not the actual error, the line below that shows that it is ignored. The real error is: Could not find a required package in 'build-packages': aclocal

2 Likes

Thank you, @sergiusens! I’ll correct my YAML file. It’s a bit embarrassing I didn’t notice!