[UPDATE] ALL Python snaps NOT working with classic confinement, even with cleanbuild

Sorry if it is just a a dumb thing that is going over my head, I’m very new to this whole snap packaging thing, but while trying to ‘snap’ my python application I found that when building and installing it it didn’t work at all. Just nothing when I tried running it, no output, no errors, just blank, and it kept going without exiting.

So instead I tried first using the example snap seen in here for testing and figuring out what was wrong with my snapcraft.yaml file but I noticed that as well if I set the confinement to classic instead of devmode or strict it would stop working in the same manner as my application.

The snapcraft.yaml file in the example link shown above looks something like this:

name: httpstat
version: '1.1.3'
summary: Curl stats simple
description: |
  httpstat is something
grade: stable
confinement: devmode # switching to classic breaks it
    source: https://github.com/reorx/httpstat.git
    source-tag: v1.1.3
    plugin: python
    stage-packages: [curl]
    command: httpstat

And I tested both my app and this example app using Ubuntu 18.04 and 16.04 (although it shouldn’t really matter as I used the cleanbuild option)

I need my application to be in a classic confinement because it needs to read some system folders for it to work and also needs to read and write some config files located in the user’s home folder.

EDIT: Seems actually that this problem is not exclusive with my app or with the example I mentioned above, since I followed the exact same steps seen here of an application (asciinema) specifically designed to be a classic snap also doesn’t work either. To reproduce simply:

  1. Init snapcraft and copy and paste exactly what is in the page above onto snapcraft.yaml
  2. Build the snap (in my case snapcraft cleanbuild) and wait for it to finish
  3. Install the freshly created .snap file
  4. Try running the application with asciinema
  5. See that nothing happens at all…

Again, I’ve tested building and installing these on several Ubuntu 18.04 and 16.04 VMs with no success with the latest non-beta snapcraft (2.42.1) and even sometimes beta (2.42.1+18.4), so any kind of help or info would be appreciated :frowning_face: