Unsupported version 0 of Verneed record [Linux 6.0]

(follow up of https://github.com/lxc/lxd/issues/11005)

I can reproduce this issues on 6.0 and 6.0.1 on 2 independant devices.

I am also seeing this issue with other snaps, not just happening with lxd, e.g. intellij-idea-ultimate. The later crashes with a jvm crash.

Rebooting pushes the problem 2 days away…

1 Like

I’ve now hit the same issue on my production cluster running mainline Linux 6.0.1.

This appears to be a squashfs kernel bug, I’ll be trying this experimental fix: https://lore.kernel.org/all/20221015205936.5735-1-phillip@squashfs.org.uk/

So far so good, will only know for sure in a day or so though.

1 Like

And broken again, so that’s sadly not sufficient.

According to the above email thread …this potentially impacts all snaps.
For my case, it’s linux: linux-libre 6.0.1 (without the patch suggested in the email thread…) snap: chromium 106.0.5249.119 2136 latest/stable canonical

the actual patch set for the fix is here:


1 Like

Does anyone know when it’s going to be applied? I have kernel 6.0.2-76060002-generic and still having the issue! Thanks

I experienced this too on Manjaro-ARM as I’m running Snap packages and ‘nextcloud-snap’ on a Rapsberry Pi 4 8GB Ram model.

Downgrading the kernel and dependent packages to 5.19.9 is my workaround for the time being.

I have the same issue on Arch Linux with nextcloud-snap.

Same issue with Arch Linux with code-insiders snap. Kernel version: 6.0.5-arch1-1.

Same issue on Fedora with Flutter.

Rebooting solved the issue but I wonder if this is true:

only switching away from a 6.x kernel will “fix” it for the moment until the breakage in the squashfs readahead code is fixed (the issue happens very randomly and in unpredictable time frames):


As to this statement, it seemed resolved to me for about 3 hours.

Just like @ogra says:

I’m having the same error:

lsb_release -a
No LSB modules are available.
Distributor ID: Pop
Description:    Pop!_OS 22.04 LTS
Release:        22.04
Codename:       jammy

uname -a      
Linux drunck 6.0.2-76060002-generic #202210150739~1666289067~22.04~fe0ce53 SMP PREEMPT_DYNAMIC Thu O x86_64 x86_64 x86_64 GNU/Linux

snap version
snap    2.57.5+22.04
snapd   2.57.5+22.04
series  16
pop     22.04
kernel  6.0.2-76060002-generic

Should be fixed with linux 6.0.7, see https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.0.7


Another temporary solution until it is resolved is to choose 5.x version from grub menu and then boot up.

1 Like

Fixed on Fedora 36. The kernel is now 6.0.7 now.

1 Like