Unable to remove old overrides from snap-store-proxy

I’m attempting to use:
snap-store-proxy delete-override lxd 4.0/stable

to remove an old override that was set, but i’m getting an error that:
lxd cannot be overridden to channel stable due to being grade: devel

$ snap-proxy list-overrides lxd
lxd stable amd64 21390 (upstream 21497)
lxd candidate amd64 21390 (upstream 21554)
lxd 4.0/stable amd64 21123 (upstream 21545)
lxd 4.17/stable amd64 21390 (upstream 21390)
lxd 4.17/candidate amd64 21390 (upstream 21390)

Maybe i’m missing something? Is there a way to remove these old overrides?

$ snap-store-proxy delete-override lxd 4.17/stable
Failed to set override:
lxd cannot be overridden to channel 4.17/stable due to being grade: devel

$ snap-store-proxy delete-override lxd 4.0/stable
Failed to set override:
lxd cannot be overridden to channel 4.0/stable due to being grade: devel

$ snap-store-proxy delete-override lxd stable
Failed to set override:
lxd cannot be overridden to channel stable due to being grade: devel