Ubuntu-image command crashed

The cloud-init config that we have confirmed to work is formatted like this:

#cloud-config
datasource_list: [NoCloud]
users:
  - name: ubuntu
    sudo: "ALL=(ALL) NOPASSWD:ALL"
    lock_passwd: false
    ssh_authorized_keys:
      - "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQC+5T1gxW1X4bzQs5a858MMMyOb8ZHKlA9EOoCJ1X0B9TdY+Dz37wiGIKQ0pSUJ39wq9gFsF5e/aG0FNcZxkzBwNwWKpZ9efeNHca/8ffKZH97l9MbQL0d+g0p+KVpP9waS3cbcyEmcTXkZZssyWAx7j8DtNI+qVp6ZZ4uPS4uRKRxhI/XwUvQYvtjHCqvZ31+cV1b0cWoRIEVjAyrlGYhAIoADs8lFEDmH1DXwgPtifj1ooPdiwcgYtZcnRuxSSNQFKXY79MhRRfcJCebCRewOPd6xjQGH8z7dbhx+kvJTO0qw7xMh6HOj20xezlEhTCTg3ykk2whodUb+sUjXkdLUULCJgma8v8r2cUKC5ec3iOfLx8esAQOxTgq/PvrUcnzPLSPrvupJV6JhXNoIa2+5XELmTV9CdFHjPiO4YHOQHxi0XayKGOODcT72zI1oc5rMOkU+7B1Lopozd9IrwmswPcZP4oSy4qm5ckHErE2IlL179fRChVEfCK9FBxNluNUZTZ0Nq4s3NDoc+JTotod8JHRTfbLnQBxzccSuJhM1oez6aYQySSpgQhcyItA0OlPdXIR9UhHDq1GFua5vu44OQX8ml4SOyCQlrXUowecptg+Qm12l1a8NspityR9uGgwdWHEkB0P2vvuJuV8ugwY2saqrZu/3eYICLuFsqMJm0w== ian.johnson@canonical.com"

Perhaps you need to include datasource_list: [NoCloud] in your config? I don’t know how cloud-init internally decides if it’s used or not, but all snapd does to decide if cloud-init should be disabled or not is by querying if there is a datasource being used or not.

1 Like

It works for me. A new user got created by my cloud.conf file. :slight_smile: :+1:

1 Like

Yep. Adding datasource_list to my cloud.conf file seems to fix things. Both the write_files and runcmd directives seem to have been processed.

1 Like

Great thanks for confirming, I’ll make a note of this in my upcoming UC20 and cloud-init doc page

1 Like

@ijohnson in the new version of UC, is there a plan to use the old way in uc18 to include the cloud.conf file when ubuntu-image command runs? Thanks. :slight_smile:

There is not currently a plan for that, no.

1 Like

Thanks @ijohnson for the confirmation. When ubuntu-image runs, can we copy the file to ubuntu-seed directory, <ubuntu-seed>/data/etc/cloud/cloud.cfg.d/ with filenames ending with .cfg as you mentioned here, Ubuntu-image command crashed?

Cheers,

Hi @ijohnson
I’m building an UC20 image at the moment and try to use a cloud-init config-file for some basic setup on a fresh install (adding some users, creating some files, etc.) as I did previously with a UC18 image.
For testing I basically went along this tutorial: https://ubuntu.com/core/docs/custom-images

Since I don’t want to create my own gadget.snap at the moment, I’m trying out your option 2, but it doesn’t seem to work for me. I build the UC20 image using ubuntu-image, then mount the ubuntu-seed partition of the finished image, create a directory <seed>/data/etc/cloud/cloud.cfg.d/ and copy a simple cloud.cfg (I tried cloud.conf as well) in there:

#cloud-config
datasource_list: [ NoCloud, None ]
users:
  - name: ubuntu
    homedir: /home/ubuntu
    sudo: ALL=(ALL) NOPASSWD:ALL
    groups: users, admin
    shell: /bin/bash

chpasswd:
  list: |
    ubuntu:ubuntu
  expire: False

My problem is, that this file doesn’t seem to be used when I later boot up the image (no user is created) and I’m not sure where to look for log-files in UC20.

Also the table you wrote into post Ubuntu-image command crashed confused me a bit. Is it possible the “Methodes” in this table are in the wrong order?

1 Like

@tobid can you show the model assertion for your image?

@ijohnson sure (just omitted my IDs):

{
  "type": "model",
  "series": "16",
  "base": "core20",
  "model": "my-pc",
  "architecture": "amd64",
  "authority-id": "...",
  "brand-id": "...",
  "timestamp": "2021-07-26T10:51:52+00:00",
  "grade": "signed",
  "snaps": [
    {
      "name": "pc",
      "type": "gadget",
      "default-channel": "20/stable",
      "id": "UqFziVZDHLSyO3TqSWgNBoAdHbLI4dAH"
    },
    {
      "name": "pc-kernel",
      "type": "kernel",
      "default-channel": "20/stable",
      "id": "pYVQrBcKmBa0mZ4CCN7ExT6jH8rY1hza"
    },
    {
      "name": "core20",
      "type": "base",
      "default-channel": "latest/stable",
      "id": "DLqre5XGLbDqg9jPtiAhRRjDuPVa5X1q"
    },
     {
      "name": "snapd",
      "type": "snapd",
      "default-channel": "latest/stable",
      "id": "PMrrV4ml8uWuEUDBT8dSGnKUYbevVhc4"
    },
    {
      "name": "htop",
      "type": "app",
      "default-channel": "latest/stable",
      "id": "hJmReLmgXSUj4SF7WhyTVRV6IzUa4QUZ"
    }
  ]
}

In order to use cloud.conf on ubuntu-seed with UC20, you need to have grade: dangerous in your model assertion as indicated by the table above. The work for enabling this to work for grade: signed is not yet complete.

2 Likes

Thanks for the info, I’m going to try this.

I think I was a bit confused by that table. If I understand it right, I’m going for “Option 2” in your post which is described as

  1. Put it in the ubuntu-seed partition at <ubuntu-seed>/data/etc/cloud/cloud.cfg.d/ with filenames ending with .cfg"

which says is allowed under these conditions:

Option 2 is allowed only with model assertion grade dangerous and signed (so this does not work for secured).

The table on the other hand has this option in the first line (named “Ubuntu-seed”, I guess), with different allowed grade. If this is a mistake in the post, maybe you could update it?

sorry the option descriptions in that comment were out of order, I have fixed it now

1 Like