Ubuntu Core 20 not booting

Hi all,

I have tried to install UC20 on my PC by using the Generic x86
image, but the booting procedure stops.

In particular, I have created a bootable USB using the previously mentioned image and then booted my PC from it (in UEFI mode). After the ubuntu-boot error, which I have read that is correct for the first boot of UC20, the following gets displayed:

And the booting procedure stops after that. Even after reboot, I get the same issue.

Do you have any idea about why this can happen?

The interesting part is just above the first line of what you have posted. Any chance you can scroll up with shift+page up?

Hi @mborzecki,

after few “manual” reboots it performed some more steps and rebooted by itself, but then it stops again with the following (I hope that’s the interesting part you are referring to):

I think that now the ubuntu-boot partition is present, since it does not give the related error anymore.

This sounds exactly like https://github.com/snapcore/core-initrd/issues/16

TLDR, I don’t think we support UC20 being installed on USB sticks like this

Oh OK, thank you @ijohnson

So, how can I use a bootable UC20 USB stick to install UC20 on another memory?
Can I do it using the core-20-amd64 image or do I need to create a custom UC20 image?
Can you tell me if this is also possible with UC18?

You can probably use UC18, it has a different initrd setup than UC20 that probably is more accommodating to this use case.

To be clear, this is a bug with UC20 we will fix soonish, but if you want to still install UC20 on internal media, the usual thing to do is to boot the device off of a USB stick with Ubuntu Server or Desktop live image, then login and dd the .img file to the internal drive. It’s not the best solution, but it does work. We will also some day work on an installer to make this flow more straight forward, but work on that has not begun yet.

1 Like

Nice, thank you @ijohnson . For the moment I will use UC18 so.

Therefore, can you tell me how to install UC18 on a “separate” memory? In particular, I would need to install it on a CFast.
I have tried to directly make it bootable (as I am used to do with USB sticks) by putting the Generic x86 core-18-amd64 image on it using Rufus, but it seems that the PC is not able to boot in this way.

EDIT: I managed to install it on the CFast by using the .img.xz file and the Disk Image Mounter of Ubuntu. I do not know why Rufus did not manage to correctly create the partitions for UC.

Rufus tries to be clever and make the device bootable itself which most likely trashes the already included boot process. A simple dd from commandline is always the cleanest way to write the UC images to a disk … or if you want it graphical simply using the Gnome Disks tool (which essentially acts as a GUI frontend to dd) as you found, to write the image helps …

OK… However, I tried to put UC 20 on a USB stick using dd but I get the same error as here:

I think I will stay on UC 18 until the bug gets fixed :slight_smile:

i dont think the-tool.service is anywhere inside the UC18 image (this is a UC20 invention) … are you sure you dd’ed the corret image file ?

EDIT: hah, i should hav read the line above the picture too :stuck_out_tongue: try with a dangerous (non TPM bound) image from:

Sorry if I was unclear, you should not be trying to put UC20 on a USB stick, even from the live environment, as I explained above no matter how you put UC20 onto the USB stick, it will not boot from there, you need to put UC20 onto internal media like the eMMC of your device or an SSD/HDD, etc. that is not removable for now.

1 Like

OK, thank you for your suggestions. I need to use a removable device for now, so I will wait for the bug fix.

Hey, I was wondering if it is possible to install a UC20 image from USB now, or if the recommended way is to use UC18 or flash from a live Ubuntu image?

My original thread is here: How do you install a custom core 20 image to a device?

Yes unfortunately the current state of things is still that you have to flash the UC20 image from another OS on the USB drive (like live ubuntu image)