Ubuntu Core 18 image for Jetson TX1 / TX2 / Nano

Hi all,

I have been taking a fresh look at the Jetson TX1 Ubuntu Core 18
images to have them based on latest nvidia developer kit (L4T). The
following repositories contain the kernel and gadget snaps for the

And this repository contains the image build scripts:

All these repositories contain instruction on how to do the
builds. The final result is a tarball that can be used jointly with
nvidia’s L4T to get the image flashed. This tarball is also in github
so you do not need to build everything from scratch:

Exact instructions on how to flash Ubuntu Core can be found inside the

Note that these images work only for Jetson TX1. Also, these images are not
supported and not official in any way. Patches for bug fixing/support
for TK1/TX2/AGX Xavier are welcome :).

EDIT: I have blogged about some details of this image: https://www.alfonsobeato.net/arm/porting-ubuntu-core-18-to-nvidia-jetson-tx1-developer-kit/

UPDATE: Now TX2 is supported too! The TX2 image and an updated TX1 image can be downloaded from the releases page: https://github.com/alfonsosanchezbeato/jetson-ubuntu-core/releases

UPDATE: Jetson Nano has now also its image! Check out in https://github.com/alfonsosanchezbeato/jetson-ubuntu-core/releases

– Alfonso


Hi Alfonso,

I’m working on a snap bundled firmware for our Jetson based products and could work on TX2 & Xavier - both are sitting on my desk.

But if I’m not wrong Ubuntu Core doesn’t support classic snaps which is a problem for me because didn’t find another way to use the hardware accelerated GStreamer provided from NVidia. So did you manage to use the hardware acceleration on TX1 under Ubuntu Core?




@palavrov I have not tried accelerated payloads yet, but I’m using the nvidia kernel, which should support HW acceleration on its side. There is no intrinsic reason for confined snaps, the only ones supported by Ubuntu Core, not to be able to use HW acceleration, but maybe some new interface that provides access to those capabilities needs to be developed. You could propose changes / new interfaces like those in https://github.com/snapcore/snapd/tree/master/interfaces/builtin .

If using a classic snap makes things easier for you, you could try to use the kernel in the snap in the nvidia image and install snapd. The kernel patches on top of the nvidia kernel should allow you to run snaps on classic Ubuntu.

Snapd comes preinstalled on Xavier SDK (L4T 31.1) i.e. don’t need to do anything for now. But Ubuntu Core image is still a good alternative to simplify the build and final firmware distribution. In few weeks will get back to the subject and will try to adapt and run your snap core on tx2 & xavier. Hope that it would not need weeks as if start from scratch.

The snaps probably will not need much changes, at least for the TX2, but partitioting seems to be quite different, so maybe that is what will require more changes. Keep us posted!

@palavrov I have now a working image for TX2, feel free to give it a try (see link in the updated post).


Sorry, didn’t have time to work on that last few weeks and probably will not have time during the next few weeks too - migrating to Ubuntu Core is still on the pipeline but there are too much other tasks with higher priority.

I am actually interested to figure out if there was any progress made for enabling UbuntuCore on Jetson Xavier NX, I might be able to have my hands on that thing in future.

Also @abeato, can you tell if Canonical’s recent parnership with NVIDIA will improve anything for the Jetson platform in terms of official Ubuntu Core support ?

@om26er for the moment I have not worked on the Xavier NX enablement, I do not have the hardware around. I guess it should not be too hard to add support for it though. As usual, patches are welcome :slight_smile:

For the Jetson situation, I do not think there is any change.

1 Like

I tried running nano image from release tab and also following the above instructions(making image). Either way the image is not booting up. @abeato
Note: after the flash it makes 13 partition that means the flash was successful. And tested by flashing multiple times even using Win32DiskImager.

Could you share the console log?

@abeato unfortunately there is no console as we do not get serial console. It does not move forward to splash screen, so no serial. Is it working with your jetson Nano? If it is, can you tell me which jetson nano is it 1)devkit 2 GB, or 2) emmc 4GB

I have worked only with the SD card one, so it is quite probable that things do not work with the eMMC version. FYI the tarball with the Nano release is https://github.com/alfonsosanchezbeato/jetson-ubuntu-core/releases/download/v0.5/core-18-jetson-nano.tar.xz

@abeato yes I tried that image again and its not working
Development kit: 2Gb jetson nano.
Is it working on your board?

Yes, it works for me…