Tried to install quelea (presentation software) from Chrome/Linux-beta


#21

Awesome, sounds great! Themes in JavaFX usually involve hacking around with CSS and then adding that on as a platform specific extension, which isn’t something I’ve had a serious look at doing as of yet - I may get around to it at some point though.

Cool, I’ll give that a go when we’re ready to release to stable, thanks!


#22

Im so frustrated Ive tried every way possible to install this but it wont work. Open LP loads and runs fine.


#23

We need @zyga to answer as to the status of snappy on Chrome OS for us to be able to see whether installing the Quelea snap on your Chromebook would be feasible, sorry. Alternatively you could use crouton (which I mentioned earlier) to install a GNU/Linux distribution, then install Java on that, then run the Quelea Jar. Or you may be able to install Java on your Chromebook, try downloading the JRE here (try the 8u192 jre-8u192-linux-i586.tar.gz (if this is 32-bit Chrome OS) or jre-8u192-linux-x64.tar.gz (for 64-bit Chrome OS)) and then running Chrome OS on that. If you’re happy using OpenLP then just use that for the time being, at the moment it might just be that OpenLP runs on Chrome OS and Quelea doesn’t, that might just be how it is.

@berry120 Also, before you hit stable ask how you can make yourself (or a Quelea account which you could ask Quelea to be transferred to) a verified publisher so you get a tick next to your name so that users know they can trust the snap :slight_smile:
Edit: this might not be possible but you could mention it when you ping popey for snap promotion :slight_smile:


#24

So grateful for your response. Openlp is just not worth switching to linux for. We already use Easislides (Windows) which gives is the ability to import set files from worshipteam.com (Openlp doesnt) and use background videos fairly easily. I really want out of windows and Quelea in the Windows trial run is nice so I can taste the answer to all my problems if I can just get this installed. I considered crouton but it seems a little more daunting than necessary might as well give in and just stay in Windows.


#25

Oh and Quelea can import set files from worshipteam.com? Sounds cool! Hopefully we’ll hear about snapd’s status on Chrome OS at some point and then running Quelea on Chrome OS may be more of a possibility! :slight_smile:


#26

Another thought: ChromeOS is not on the list of supported distributions but GalliumOS is. GalliumOS is Xubuntu adapted for Chromebooks and is installed using chrx (might also be too involved for your liking). Again, until we hear from zyga, we won’t know about the status of snappy on ChromeOS itself…


#27

worshipteam.com requires a subscription but the user interface is amazing and versatile. It also covers rights for copying and peforming (streaming license needed as extra)as well as giving the ability to modify keys print charts communicate with team members organize events and team members and skills. But whats really cool is that you can export the entire set in your choice of formats such as EasyWorship LiveWorship (CCLI format) MediaShout PowerPoint SongShow Plus and ProPesenter. The way Quelea imports is very slick and I would like to figure out how to utilize the Stage screen feature without needing to manually add evreything (if possible).


#28

So… tried to install GalliumOS (dual boot) bad idea seems the firmware update may not support keyboard and I was able to install and boot until I needed keyboard to login. My Acer CB3-532 onky has 16 GB so as can imagine I had not enough resource message when I booted into Crome. I did a recovery and back to scratch. So next step is to try and make a bootable USB and run it from there which seems possible.


#29

I never thought that Chromebooks were suitable for running native applications because of that tiny hard drive space. Cheap but good certified refurbished laptops (particularly ThinkPads) are much better in general in my opinion. But since you own a Chromebook and want to use it for Quelea we’ll have to make do I suppose.

I’m surprised that 16 GB is not enough even to run two operating systems though, maybe Chrome has a very big cache or you have a lot of GNU/Linux apps installed on Chrome OS?


#30

I’ve noticed we’re getting an issue when showing the native save dialog - the following is displayed and the app hard freezes. Don’t suppose you have any ideas?

(java:27494): GLib-GIO-WARNING **: Error creating IO channel for /proc/mounts: Permission denied (g-file-error-quark, 2)

(java:27494): GLib-GObject-WARNING **: cannot register existing type 'GtkIMContext'

(java:27494): GLib-GObject-WARNING **: cannot add private field to invalid (non-instantiatable) type '<invalid>'

(java:27494): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(java:27494): GLib-GObject-CRITICAL **: g_type_register_dynamic: assertion 'parent_type > 0' failed

#31

I’ve never successfully made a snap myself, I’m no developer which I think didn’t help because I just don’t know enough to be able to debug properly.

You could try the ‘Identify missing interfaces’ part of this doc?


#32

Ah thanks - I’ll give it a go and see!


#33

@berry120 Did you solve the dialog issue?
I’m having the exact same problem


#34

@LyzardKing Should be sorted in the latest edge release - could you give that a try?


#35

Yes, it works, did you use gtk2 instead of gtk3?


#36

@LyzardKing Yup - gtk3 seemed to cause a whole bunch of issues with dialogs crashing (and occasionally window borders disappearing too it seems.)


#37

@Ads20000 and any others who may be interested - the stable version of the snap is now out in the wild :slight_smile: